mixi.jp sends the desktop version for Firefox on Mobile

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: karlcow, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form] [country-jp] [serversniff] [sitewait] [clientsniff], URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

4 years ago
Site: http://mixi.jp/
mixi.jp sends the desktop version for Firefox on Mobile

:: Steps To Reproduce

1. With Firefox OS or Firefox Android
2. Go to http://mixi.jp/


:: Expected Result

Get the mobile content like Opera Mobile

:: Actual Result

Received the Desktop Content.

:: Additional Information

Software Version: 1.2
Device Information: ZTE roamer2
Reporter's User Agent: Mozilla/5.0 (Mobile; ZTEOpen; rv:25.0) Gecko/25.0 Firefox/25.0
(Assignee)

Updated

4 years ago
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [country-jp]
(Assignee)

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

4 years ago
This is also happening once the user is being logged. 

The User agent detection is happening both on the server side and the client side. On the client side they are using the Zepto library. For example: 

    window.Zepto=Zepto

in http://mixi.jp/static/js/mixi/touch/mixi.js

# iOS Safari
→ http -b GET http://mixi.jp/ "User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3" |
 grep -i "html class"
<html class="osIOS browserSafari browserSafari75 pageHomeJpMixi domainJpMixi">

# Firefox Android
→ http -b GET http://mixi.jp/ "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" | grep -i "html class"
<html class="osAndroid browserFirefox browserFirefox18 serviceLogoutQuirks pageHomeJpMixi domainJpMixi">

# Firefox OS
→ http -b GET http://mixi.jp/ "User-Agent: Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" | grep -i "html class"
<html class="osUndefined browserFirefox browserFirefox18 serviceLogoutQuirks pageHomeJpMixi domainJpMixi">
Whiteboard: [mobile-compat-form] [country-jp] → [mobile-compat-form] [country-jp] [serversniff] [contactready] [clientsniff]
Created attachment 8360930 [details]
mixi.json -problem report

Still a problem, affects both Firefox on Android and Firefox OS. According to the CSS analysis, the stuff they send to the iPhone has quite a lot of -webkit- CSS, I see no issues on the login page but presumably there are layout problems inside the site.
Created attachment 8360931 [details]
043.png
(Assignee)

Comment 4

4 years ago
Will be helpful in contacting https://github.com/mixi-inc?tab=members
(Assignee)

Comment 5

4 years ago
contactemail
Contacted Yokoma-san, one of the devs. Gave information about the UA. Let see if I get an answer.

Also Mike Taylor told me that Zepto latest version is compatible with Firefox OS.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Whiteboard: [mobile-compat-form] [country-jp] [serversniff] [contactready] [clientsniff] → [mobile-compat-form] [country-jp] [serversniff] [sitewait] [clientsniff]
(Assignee)

Comment 6

4 years ago
OK got a reply from Mixi CTO, who kindly acknowledged the issue. 
They are working on it and they will tell us when it is solved. 
A bit of Mixi love is good.
(Assignee)

Updated

3 years ago
Blocks: 1057221
(Assignee)

Comment 7

3 years ago
Since the opening of this bug, the Web site has changed a lot. 
First of all, Mixi changed its strategy and now there is public content accessible from the home page. 

Here comes the list of old and new issues. 

* Receive Desktop version instead of Mobile version of the site:
  Firefox Android (gecko), Firefox OS (gecko), Opera (blink), UCWeb (blink)
* Receive Mobile version
  iOS Safari (WebKit), Chrome Android (blink)

Opening a secondary bug for CSS issues Bug 1057221
(Assignee)

Comment 8

3 years ago
Created attachment 8477219 [details]
mixi-opera-blink.png

Opera Blink is receiving the desktop version.
(Assignee)

Comment 9

3 years ago
Created attachment 8477222 [details]
2014-08-22-14-27-32.png

Firefox OS and Firefox Android receives the desktop version.
Attachment #8360931 - Attachment is obsolete: true
(Assignee)

Comment 10

2 years ago
contactemail
Recontacted the CTO today with the fixed CSS.
https://bugzilla.mozilla.org/show_bug.cgi?id=1057221#c5
(Assignee)

Comment 11

2 years ago
We need another contact. My previous contact was Takeshi Matsuoka, Mixi ex-CTO.

> Technical details of permanent failure: 
> Google tried to deliver your message, but it was 
> rejected by the server for the recipient domain mixi.co.jp 

The CTO must have changed.
(Assignee)

Comment 12

2 years ago
Tomoya, 
Do you know if we have other contacts at Mixi.
If not I will try to find a new one.
Flags: needinfo?(bugzilla)
(Assignee)

Comment 13

2 years ago
contactemail
Maybe another possibility
https://www.linkedin.com/profile/view?id=1793307
(Assignee)

Comment 14

2 years ago
The contact worked. The dialog is opened. :)
(Assignee)

Comment 15

2 years ago
Message from the contact on 2015-03-25

> We do have interest in solving this, 
> but the biggest problem is that our site has lots 
> of CSS files (200+ for smartphone only), and we 
> can hardly get around to fix and test (!) all of it.

I introduced them to css-fixme.
Flags: needinfo?(bugzilla)
(cssfixme now also supports a more "compact" output mode, meant to make it easier for sites like Mixi to create diffs)

Comment 17

2 years ago
Mozilla Japan has contact, will contact them.
Also, discuss on https://bugzilla.mozilla.org/show_bug.cgi?id=1057221
(Assignee)

Comment 18

2 years ago
contactemail
Recontacted Patrick asking them to give us the mobile site.
And telling them that for the CSS in the meantime we will fix it on the client side.
(Assignee)

Comment 19

2 years ago
This is fixed. \o/
Thanks to Mixi team and their hard work.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.