m.youtube.com freezes after trying to view the same video for the second time

RESOLVED WONTFIX

Status

()

Firefox for Android
Toolbar
--
major
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Flaviu Cos, Assigned: snorp)

Tracking

({reproducible})

27 Branch
All
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox26 wontfix, firefox27+ wontfix, firefox28 unaffected, firefox29 unaffected, fennec27+)

Details

(Reporter)

Description

5 years ago
Environment: 
Device: Google Nexus 7 (Android 4.4);
Build: 27 beta 4 (2014-01-07).

Steps to reproduce:
1. Go to m.youtube.com;
2. Tap on any video;
3. Tap the video again to start the video playback;
4. Tap the android back button to exit the native youtube app;
5. Tap again the android back button to get to the m.youtube.com home page;
6. Tap again on the same video from the step 2.

Expected result:
The youtube page is working fine and you can play the video again.

Actual result:
The youtube page freezes and it is working only after changing orientation to repaint the page.

Note:
The bug is reproducible on firefox 26, 27, but is not reproducible on 28 and 29
(Reporter)

Updated

5 years ago
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → unaffected
status-firefox29: --- → unaffected
If we can get a fix range then we can consider uplifting the fix to beta. Other than that it's unlikely anything will happen here. Since we already shipped 26 with this bug presumably we can let 27 out with it too.
status-firefox26: affected → wontfix
Checking the console, we seem to trigger EGL_BAD_SURFACE which floods my console and basically renders the browser useless until the browser is shutdown (i.e, any page will not display afterwards, the surface has gone bad)

E/libEGL  ( 6262): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
Keywords: reproducible

Updated

5 years ago
Severity: normal → major
tracking-fennec: --- → ?
On tap of the same front-page YouTube video again (following the steps from comment #0).

D/GeckoBrowserApp(11247): BrowserApp.onTabChanged: 0: MENU_UPDATED
I/Gecko   (11247): OpenGL version detected: 300
D/GeckoTabs(11247): handleMessage: DOMTitleChanged
D/GeckoToolbar(11247): onTabChanged: TITLE
D/GeckoBrowserApp(11247): BrowserApp.onTabChanged: 0: TITLE
I/Gecko   (11247): OpenGL version detected: 300
W/Adreno-EGL(11247): <qeglDrvAPI_eglDestroyImageKHR:4773>: EGL_BAD_PARAMETER
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
W/Adreno-ES20(11247): <core_glUseProgram:1525>: GL_INVALID_VALUE
W/TextureGenerator(11247): Clearing GL error: 0x501
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
W/Adreno-ES20(11247): <core_glUseProgram:1525>: GL_INVALID_VALUE
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)
E/libEGL  (11247): eglMakeCurrent:740 error 300d (EGL_BAD_SURFACE)

[...] and on and on

Updated

5 years ago
tracking-firefox27: --- → ?
Tracking for now, will uplift if we can find a low risk uplift by our next beta to avoid shipping with this bug in Fx27.

Updated

5 years ago
tracking-firefox27: ? → +
Apparently very easily reproduced, assigning to snorp but NI'ing edwin in case its actually his domain.
Assignee: nobody → snorp
tracking-fennec: ? → 27+
Flags: needinfo?(edwin)
Do we have an update here on a fix for 27 Snorp?
Status: NEW → ASSIGNED
NI on :snrorp so this does not miss the boat. PLease note our second last beta for FX 27 is scheduled to gtb on Monday(1/20) and will be great if we can get this in by then.
Flags: needinfo?(snorp)
I am fairly confident that this was fixed by 925608. The EGL_BAD_SURFACE errors are caused by a bad surface (surprise!), and bug 925608 and and friends improved that substantially.
Flags: needinfo?(snorp)
I should add that I do not think that 925608 is a candidate for uplift to Beta at this stage. Too many changes, IMHO.
Depends on: 925608

Updated

5 years ago
status-firefox27: affected → wontfix
Fixed on 28+ via bug 925608.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Updated

5 years ago
Flags: needinfo?(edwin)
You need to log in before you can comment on or make changes to this bug.