Closed Bug 957144 Opened 8 years ago Closed 8 years ago

OSX b2g desktop failure | test_settings_change_keyboard_language.py | NoSuchElementException: Unable to locate element: .keyboard-row button[data-keycode='-3']

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ahal, Assigned: bsilverberg)

References

Details

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=32594555&tree=Cedar

Looks very similar to bug 917474.

This is failing on OSX b2g desktop only and is the only thing stopping us from enabling b2g desktop Gu on OSX across all branches. Zac, assuming this is the same cause as bug 917474 any chance of a quick fix? Otherwise we should disable this on osx so we can turn the job on across all branches.
That is odd, this does seem to be a Mac specific thing.

It's not related to that other bug but we can investigate it anyway. I just have to push it to the team member who has a Mac.

There is a nuance of this test and that the little globe icon (that this test is trying to tap on when it fails) appears slightly after the keyboard has opened.

Bob can you look at this? You're the only ui tests guy with a Mac.
Flags: needinfo?(bob.silverberg)
Blocks: 957161
Sure, Zac, I will investigate.
Flags: needinfo?(bob.silverberg)
Assignee: nobody → bob.silverberg
Status: NEW → ASSIGNED
What I have observed, when running b2g desktop on OS X using the TBPL configuration, is that if you launch the Contacts app immediately after adding a language keyboard, then the first time the keyboard is called up there is no globe icon. It doesn't matter how long you wait for the icon, nor how long you wait after adding a keyboard - the icon doesn't appear the first time. It always appears the second time though, so if you first click on the First Name field, wait for the keyboard, and then click on the Last Name field and wait for the keyboard then the icon appears.

Also, if you navigate away from the "add more keyboards" screen after adding a keyboard (via the back button) then it all works as expected. It's as if an event isn't firing as expected to enable the button on the keyboard and something else has to happen to trigger the new keyboard being recognized.  This sounds like a bug to me, and should probably be investigated, but I am also attaching a patch to this bug which fixes the test by clicking on the back button after adding a new keyboard. I have tested this patch on desktop and device and it seems to do the trick.
Attachment #8356786 - Flags: review?(zcampbell)
Attachment #8356786 - Flags: review?(viorela.ioia)
Attachment #8356786 - Flags: review?(trifandreialin)
Attachment #8356786 - Flags: review?(florin.strugariu)
Attachment #8356786 - Flags: review?(andrei.hutusoru)
Note that this "bug" cannot be manually reproduced as hitting the home button in order to navigate from the Settings app to the Contacts app seems to be enough to make the setting "stick".
(In reply to Bob Silverberg [:bsilverberg] from comment #5)
> Note that this "bug" cannot be manually reproduced as hitting the home
> button in order to navigate from the Settings app to the Contacts app seems
> to be enough to make the setting "stick".

I guess it's not really a bug because in the real world this situation of launching the Contacts app over the top of the Settings app could never occur. (you need to tap home, then launch Contacts)
Comment on attachment 8356786 [details] [review]
Fix for test_settings_change_keyboard_language on desktop b2g on OS X

r+
Attachment #8356786 - Flags: review?(zcampbell)
Attachment #8356786 - Flags: review?(viorela.ioia)
Attachment #8356786 - Flags: review?(trifandreialin)
Attachment #8356786 - Flags: review?(florin.strugariu)
Attachment #8356786 - Flags: review?(andrei.hutusoru)
Attachment #8356786 - Flags: review+
Merged:
https://github.com/mozilla-b2g/gaia/commit/cf5f1956bcfa54bd77d51d57cad54f84a7c79fec
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.