Fix home button styling in bookmarks bar on Linux

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Toolbars and Customization
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Gijs, Assigned: mikedeboer)

Tracking

unspecified
Firefox 31
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P4])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Spun off from bug 940107.
Screenshot? Not sure how severe this is.
Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

4 years ago
(In reply to Justin Dolske [:Dolske] from comment #1)
> Screenshot? Not sure how severe this is.

You can see screenshot at https://bugzilla.mozilla.org/show_bug.cgi?id=940107
Hardware: x86 → x86_64

Comment 3

4 years ago
Screen shot of Aurora with missing home icon.

http://imgur.com/q1OGjFD
(Reporter)

Updated

4 years ago
Flags: needinfo?(gijskruitbosch+bugs)

Comment 4

4 years ago
Still missing in Firefox 29.0b1
(Assignee)

Updated

4 years ago
Assignee: nobody → mdeboer
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Created attachment 8398547 [details] [diff] [review]
Patch v1: fix styling of primary toolbar buttons on the bookmarks toolbar
Attachment #8398547 - Flags: review?(gijskruitbosch+bugs)
(Assignee)

Updated

4 years ago
Depends on: 987461
(Reporter)

Updated

4 years ago
Attachment #8398547 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 6

4 years ago
Pushed: https://hg.mozilla.org/integration/fx-team/rev/722363d66998
status-firefox29: --- → affected
status-firefox30: --- → affected
status-firefox31: --- → affected
Whiteboard: [Australis:P4] → [Australis:P4][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/722363d66998
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P4][fixed-in-fx-team] → [Australis:P4]
Target Milestone: --- → Firefox 31
(Assignee)

Updated

4 years ago
status-firefox31: affected → fixed
(Assignee)

Comment 8

4 years ago
Comment on attachment 8398547 [details] [diff] [review]
Patch v1: fix styling of primary toolbar buttons on the bookmarks toolbar

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 957151, Australis
User impact if declined: User will see the wrong/ broken styling of the Home button when placed on the Bookmarks toolbar.
Testing completed (on m-c, etc.): landed on m-c.
Risk to taking this patch (and alternatives if risky): minor.
String or IDL/UUID changes made by this patch: n/a
Attachment #8398547 - Flags: approval-mozilla-beta?
Attachment #8398547 - Flags: approval-mozilla-aurora?
Attachment #8398547 - Flags: approval-mozilla-beta?
Attachment #8398547 - Flags: approval-mozilla-beta+
Attachment #8398547 - Flags: approval-mozilla-aurora?
Attachment #8398547 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 9

4 years ago
Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/3a0bdf9fa94f
status-firefox30: affected → fixed
(Assignee)

Comment 10

4 years ago
Beta: https://hg.mozilla.org/releases/mozilla-beta/rev/e24101b952ad
status-firefox29: affected → fixed

Updated

4 years ago
Keywords: verifyme
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0
Mozilla/5.0 (X11; Linux i686; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0

Verified as fixed using Firefox 29 beta 4 (20140331125246), Aurora 30.0a2 (20140401004001) and Nightly 31.0a1 (20140331030201) under Ubuntu 32-bit.
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
status-firefox31: fixed → verified
Keywords: verifyme
QA Contact: petruta.rasa
You need to log in before you can comment on or make changes to this bug.