Missing Range request header on OS X 10.8.4.

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: andrei, Unassigned)

Tracking

26 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Steps to reproduce:

1. Create a html5 video player (my video type is mp4 and the video should be about ~40 MB ):
          <video poster="{{ video.previewurl }}" controls>
            <source type="video/mp4" src="{{ video.url }}">
          </video>
2. Because it's kind of large, 206 partial content header will be used for streaming:

Accept-Ranges:0-44812190
Access-Control-Allow-Credentials:true
Cache-Control:public, must-revalidate, max-age=0
Connection:Keep-Alive
Content-Length:76173
Content-Range:bytes 44736017-44812189/44812190
Content-Type:video/mp4
Date:Tue, 07 Jan 2014 16:37:06 GMT
Expires:Thu, 19 Nov 1981 08:52:00 GMT
Keep-Alive:timeout=15, max=98
Pragma:no-cache

3. Press Play and after 5 seconds press Pause.
4. Wait about 15 minutes.
5. Press Play again.


Actual results:

HTML5 player will freeze after ~5 seconds and reloads the video.


Expected results:

Streaming should continue from where it was paused.
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.