Crash report for "mozilla::Maybe<nsAutoString>::~Maybe()" doesn't link to bug report that was filed for it

RESOLVED DUPLICATE of bug 865146

Status

RESOLVED DUPLICATE of bug 865146
5 years ago
5 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Bug 957006 was filed from the Socorro interface, for bp-ebc8b6e8-7560-4267-b3e1-b0a8b2131231.

However, the crash report doesn't list the bug in its "Related Bugs" section. (Nor do newer crash reports with the same signature, e.g. bp-332d798f-3c42-47a5-843f-a0f892140107)

AFAICT the bug was filed correctly, with the right signature, so I'm not sure why Socorro is failing to suggest the bug.

Comment 1

5 years ago
Some investigation --

I grabbed the data the cron would get from bugzilla and the signature in question was in there, but it's not listed in the bugzilla cron log output. Initially suspected the tilde was to blame but other tilde signatures get processed normally and there's nothing obvious in the parser that would treat anything but [@ and ] differently.
here's my theory: If I look at the logs for crontabber, I can see that it runs every hour.  But after 6pm PST, it logs nothing after finding no results from its bugzilla query.  The date set in the query comes from "job_information['last_success']" which I bet is UTC.  Bugzilla uses PST.  At 6pm every day, crontabber starts looking for bugs filed on a day that hasn't happened yet in the PST timezone.  

At midnight, the UTC day and PST day match and the bugzilla queries start returning results again.  However, the bug in question is NOT returned by that query because it happened on the previous day, not the current day.

Comment 3

5 years ago
filed 957301 to rewrite the cron. Should fix this too.
Depends on: 957301
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 957301
Resolution: --- → DUPLICATE
Duplicate of bug: 865146
You need to log in before you can comment on or make changes to this bug.