If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Valgrind test job build failure: TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync

RESOLVED DUPLICATE of bug 957455

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 957455
4 years ago
4 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

https://tbpl.mozilla.org/?tree=Try&rev=d3de6823f1cd
https://tbpl.mozilla.org/php/getParsedLog.php?id=32654588&tree=Try&full=1

My patches do not touch anything under build/ or config/, so I'm not sure where this error is coming from.
I did numerous Valgrind try runs yesterday and saw this once. I see you've retriggered and the second run was green, which is good. So it sounds like something isn't being cleaned up correctly.
Summary: Valgrind check-sync-dirs.py build error on try → Valgrind test job build failure: TEST-UNEXPECTED-FAIL | check-sync-dirs.py | build file copies are not in sync
It sounds like a non clean mercurial checkout.
I wonder if it's related to bug 957455.

Comment 4

4 years ago
Likely a dupe bug 957455; please reopen if this still occurs now that has been fixed :-)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 957455
I don't follow why this is a duplicate, as there's no evidence of hg checkout problem. Instead, this probably a bad parent to push from, eg http://hg.mozilla.org/try/file/d3de6823f1cd/js/src/build/ has no autoconf directory at all.
Ok, that's normal. I'm not sure what went wrong here.
You need to log in before you can comment on or make changes to this bug.