Closed Bug 957359 Opened 6 years ago Closed 6 years ago

Intermittent webaudio mochitest | Assertion count N is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished')

Categories

(Core :: Web Audio, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- fixed
firefox-esr24 --- unaffected

People

(Reporter: RyanVM, Assigned: karlt)

References

Details

(Keywords: assertion, intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=32648512&tree=Mozilla-Inbound

Ubuntu VM 12.04 x64 mozilla-inbound debug test mochitest-1 on 2014-01-07 10:04:37 PST for push dd1d484f6d22
slave: tst-linux64-spot-459

11:03:53     INFO -  160195 INFO TEST-START | /tests/content/media/webaudio/test/test_delayNodeTailWithDisconnect.html
11:03:53     INFO -  ++DOMWINDOW == 21 (0x47a9538) [pid = 2356] [serial = 5153] [outer = 0x1f28b08]
11:03:53     INFO -  System JS : ERROR (null):0 - uncaught exception: 2147746065
11:03:53     INFO -  disconnecting
11:03:53     INFO -  [Parent 2356] ###!!! ASSERTION: Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished', file ../../../content/media/MediaStreamGraph.cpp, line 398
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b5162]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b57da]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008cb2b2]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00867d31]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ae0fc1]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace092]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace0ba]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008ca972]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libnspr4.so +0x0002e905]
11:03:53     INFO -  UNKNOWN [/lib/x86_64-linux-gnu/libpthread.so.0 +0x00007e9a]
11:03:53     INFO -  clone+0x0000006d [/lib/x86_64-linux-gnu/libc.so.6 +0x000f3dbd]
11:03:53     INFO -  [Parent 2356] ###!!! ASSERTION: Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished', file ../../../content/media/MediaStreamGraph.cpp, line 398
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b5162]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b57da]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008cb2b2]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00867d31]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ae0fc1]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace092]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace0ba]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008ca972]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libnspr4.so +0x0002e905]
11:03:53     INFO -  UNKNOWN [/lib/x86_64-linux-gnu/libpthread.so.0 +0x00007e9a]
11:03:53     INFO -  clone+0x0000006d [/lib/x86_64-linux-gnu/libc.so.6 +0x000f3dbd]
11:03:53     INFO -  [Parent 2356] ###!!! ASSERTION: Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished', file ../../../content/media/MediaStreamGraph.cpp, line 398
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b5162]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b57da]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008cb2b2]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00867d31]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ae0fc1]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace092]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace0ba]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008ca972]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libnspr4.so +0x0002e905]
11:03:53     INFO -  UNKNOWN [/lib/x86_64-linux-gnu/libpthread.so.0 +0x00007e9a]
11:03:53     INFO -  clone+0x0000006d [/lib/x86_64-linux-gnu/libc.so.6 +0x000f3dbd]
11:03:53     INFO -  [Parent 2356] ###!!! ASSERTION: Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished', file ../../../content/media/MediaStreamGraph.cpp, line 398
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b5162]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x017b57da]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008cb2b2]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00867d31]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ae0fc1]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace092]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x00ace0ba]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libxul.so +0x008ca972]
11:03:53     INFO -  UNKNOWN [/builds/slave/test/build/application/firefox/libnspr4.so +0x0002e905]
11:03:53     INFO -  UNKNOWN [/lib/x86_64-linux-gnu/libpthread.so.0 +0x00007e9a]
11:03:53     INFO -  clone+0x0000006d [/lib/x86_64-linux-gnu/libc.so.6 +0x000f3dbd]
11:03:53     INFO -  System JS : ERROR (null):0 - uncaught exception: 2147746065
11:03:53     INFO -  --DOMWINDOW == 20 (0x59eddb8) [pid = 2356] [serial = 5133] [outer = (nil)] [url = http://mochi.test:8888/tests/content/media/webaudio/test/test_convolverNodeChannelCount.html]
11:03:53     INFO -  forced GC
11:03:53     INFO -  --DOMWINDOW == 19 (0x15e6ac8) [pid = 2356] [serial = 5150] [outer = (nil)] [url = http://mochi.test:8888/tests/SimpleTest/iframe-between-tests.html]
11:03:54     INFO -  System JS : ERROR (null):0 - uncaught exception: 2147746065
11:03:54     INFO -  System JS : ERROR (null):0 - uncaught exception: 2147746065
11:03:55     INFO -  160196 INFO TEST-PASS | /tests/content/media/webaudio/test/test_delayNodeTailWithDisconnect.html | Channels must have the same length
11:03:55     INFO -  160197 INFO TEST-PASS | /tests/content/media/webaudio/test/test_delayNodeTailWithDisconnect.html | Found 0 different samples, maxDifference: 0, first bad index: -1 with source offset 0 and destination offset 0
11:03:55     INFO -  160198 INFO TEST-INFO | MEMORY STAT vsize after test: 1995808768
11:03:55     INFO -  160199 INFO TEST-INFO | MEMORY STAT residentFast after test: 449490944
11:03:55     INFO -  System JS : ERROR (null):0 - uncaught exception: 2147746065
11:03:55     INFO -  160200 INFO TEST-END | /tests/content/media/webaudio/test/test_delayNodeTailWithDisconnect.html | finished in 2202ms
11:03:55     INFO -  ++DOMWINDOW == 20 (0x5d43aa8) [pid = 2356] [serial = 5154] [outer = 0x1f28b08]
11:03:55     INFO -  160201 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/webaudio/test/test_delayNodeTailWithDisconnect.html | Assertion count 4 is greater than expected range 0-0 assertions.
Blocks: 943461
Depends on: 939610
See Also: → 957687
Summary: Intermittent test_delayNodeTailWithDisconnect.html | Assertion count 4 is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished') → Intermittent test_delayNodeTailWithDisconnect.html,test_channelMergerNode.html | Assertion count n is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished')
Duplicate of this bug: 957687
https://tbpl.mozilla.org/php/getParsedLog.php?id=32718297&tree=Mozilla-Central
https://tbpl.mozilla.org/php/getParsedLog.php?id=32716927&tree=Fx-Team
Summary: Intermittent test_delayNodeTailWithDisconnect.html,test_channelMergerNode.html | Assertion count n is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished') → Intermittent test_delayNodeTailWithDisconnect.html,test_channelMergerNode.html | Assertion count N is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished')
Depends on: 957832
Duplicate of this bug: 957871
Summary: Intermittent test_delayNodeTailWithDisconnect.html,test_channelMergerNode.html | Assertion count N is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished') → Intermittent webaudio mochitest | Assertion count N is greater than expected range (Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished')
Duplicate of this bug: 957879
https://tbpl.mozilla.org/php/getParsedLog.php?id=33178244&tree=Fx-Team

Roc, these aren't going away on their own. If you can't reproduce, can you please help find someone who can?
Flags: needinfo?(roc)
Blocks: 957620
Blocks: 962006
Blocks: 962010
Blocks: 961699
Ubuntu VM 12.04 x64 mozilla-inbound debug test mochitest-1 on 2014-01-21 17:16:04 PST for push 90d56ff72f1a
https://tbpl.mozilla.org/php/getParsedLog.php?id=33364446&tree=Mozilla-Inbound

indicates that the assertion could fail when bug 943461 first landed
and

https://tbpl.mozilla.org/?tree=Try&rev=929a306e8a81
indicates that the assertion failed when first added in
http://hg.mozilla.org/mozilla-central/rev/fcc3f7ba913e
so I'll change this to a warning and the root cause can be fixed in bug 957832 when that is a priority.
QA Contact: karlt
Given this was a soft NS_ASSERTION, not a fatal MOZ_ASSERT, I assume nothing in bug 943461 is desperately needing this condition to hold.
Assignee: nobody → karlt
Status: NEW → ASSIGNED
Attachment #8363453 - Flags: review?(paul)
QA Contact: karlt
Comment on attachment 8363453 [details] [diff] [review]
change failing assertion to warning

I'm also in the process of digging into this, I can somewhat repro locally, but we can take this for now.
Attachment #8363453 - Flags: review?(paul) → review+
Blocks: 963101
https://hg.mozilla.org/mozilla-central/rev/931b7b9749bc
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
No longer blocks: 957620
Duplicate of this bug: 957620
No longer blocks: 961699
Duplicate of this bug: 961699
No longer blocks: 962006
Duplicate of this bug: 962006
No longer blocks: 962010
Duplicate of this bug: 962010
No longer blocks: 963101
Duplicate of this bug: 963101
No longer depends on: 939610
Nothing too interesting in this stack, but it indicates this bug has not been fixed yet.

Ubuntu VM 12.04 try debug test mochitest-1
https://tbpl.mozilla.org/php/getParsedLog.php?id=35514268&full=1&branch=try#error0

[Parent 2484] ###!!! ASSERTION: Shouldn't have already notified of finish *and* have output!: '!streamHasOutput[i] || !stream->mNotifiedFinished', file /builds/slave/try-lx-d-000000000000000000000/build/content/media/MediaStreamGraph.cpp, line 406
mozilla::MediaStreamGraphImpl::UpdateCurrentTime() [content/media/MediaStreamGraph.cpp:405]
mozilla::MediaStreamGraphImpl::RunThread() [content/media/MediaStreamGraph.cpp:1167]
mozilla::::MediaStreamGraphInitThreadRunnable::Run [content/media/MediaStreamGraph.cpp:1391]
nsThread::ProcessNextEvent(bool, bool*) [xpcom/threads/nsThread.cpp:643]
NS_ProcessNextEvent(nsIThread*, bool) [xpcom/glue/nsThreadUtils.cpp:263]
mozilla::ipc::MessagePumpForNonMainThreads::Run(base::MessagePump::Delegate*) [ipc/glue/MessagePump.cpp:304]
Depends on: 962719
No longer depends on: 957832
You need to log in before you can comment on or make changes to this bug.