[Facebook] Cannot check in on Facebook - "There as an error detecting your current location."

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
10 months ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 8356887 [details]
Logcat captured during testing

Buri, while running:

Gaia   9f30198a420632359b271de7e680abde92ccbcd6
SourceStamp e7a366c1036c
BuildID 20140107040206
Version 29.0a1

STR:
1. Install Facebook app
2. Receive attached screenshot

GPS setting is pref'd on.

Attaching logcat as well.
Created attachment 8356892 [details]
Screenshot of issue
Alexandre - Is this by chance a dupe of bug 955906?
Flags: needinfo?(lissyx+mozillians)
(In reply to Jason Smith [:jsmith] from comment #2)
> Alexandre - Is this by chance a dupe of bug 955906?

I'm not sure, there is the geolocation icon here. We would need to investigate more, but for now I'd say that this not a dupe.
Flags: needinfo?(lissyx+mozillians)
I do see calls to location service in the logcat, so I'd suspect it's something else. Julien told me yesterday we might have a regression regarding A-GPS' APNs. That might be explaining those lines:

E/LocSvc_api_rpc_glue(  136): I/---> loc_ioctl line 557 RPC_LOC_IOCTL_SET_SUPL_VERSION
E/LocSvc_libulp(  136): I/===> void* ulp_msg_main(void*) line 75 
E/RPC     (  136): 3000008c:00050000 call failed with an authentication error.
E/LocSvc_api_rpc_glue(  136): E/loc_ioctl:559] failure code 11
E/LocSvc_api_rpc_glue(  136): loc_ioctl failed select_id = 0, ioctl_type RPC_LOC_IOCTL_SET_SUPL_VERSION, returned RPC_LOC_API_RPC_FAILURE

This really does not looks like a dupe.
Okay - flagging qawanted to see if this reproduces on 1.3 or 1.2.
Keywords: qawanted
I haven't been able to get the Check in feature to work on any Firefox OS device, yet including 1.1 production ZTE Open devices:

Gaia   171ea36dfedc526cd6044bbff187215eed4e4add
SourceStamp
BuildID 20131029185531
Version 18.0

I tried an LG device from Brazil and a 1.3 Buri device using today's build with no luck. With the LG device I even attempted taking it outside the building and I eventually get the same error as in the screenshot.
Keywords: qawanted
Component: Gaia → General

Comment 7

10 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.