New snippets to promote sync/firefox accounts

RESOLVED DUPLICATE of bug 992966

Status

Snippets
General
RESOLVED DUPLICATE of bug 992966
4 years ago
4 years ago

People

(Reporter: markh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

(Reporter)

Description

4 years ago
We are aiming for Sync based on Firefox Accounts to hit desktop firefox in the 29 cycle and as a part of this, we would like a snippet to promote the use of sync.

The wording will be something like "Sync is brand new and easier than ever. [Let's get started]"

The 2 complications I see are:

* We only want to promote this to users who don't currently have sync setup.  According to https://wiki.mozilla.org/Firefox/Projects/Firefox_Start/Snippet_Service#Client_match_rules, we don't currently have a way of filtering based on this.

* The "[Let's get started]" portion should be a link that opens (probably) an about:sync-setup or similar page (either in a new tab, or replacing the about:home tab - not yet clear).  I'm not sure if/how the snippets infrastructure supports this.
/me wonders if there should be an Android equivalent of this bug and whether or not we want to open an issue in the fxa-content-server GitHub repo for the main UX/UI work for this...
Whiteboard: [qa+]
Per the Sync meeting today and IRC discussion with jgruen, we're going to postpone this until post-29 (given the complications mentioned in comment 0).
No longer blocks: 951296
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 992966
You need to log in before you can comment on or make changes to this bug.