Consider using consistent naming of FxA-specific configs

RESOLVED FIXED in mozilla29

Status

Cloud Services
Firefox Sync: UI
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jbonacci, Assigned: ttaubert)

Tracking

unspecified
mozilla29
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa+])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
We have the following configs defined right now:
identity.fxaccounts.enabled
identity.fxaccounts.auth.uri
firefox.accounts.remoteUrl
identity.fxaccounts.auth.uri

And for sync (among many others):
services.sync.tokenServerURI
services.sync.clusterURL


If we are going to keep "firefox.accounts.remoteUrl", consider changing it to "identity.fxaccounts.remoteUrl" so that it is easier to find.
(Reporter)

Updated

4 years ago
Blocks: 951296
Whiteboard: [qa+]
Component: Server: Firefox Accounts → Firefox Sync: UI
QA Contact: jbonacci
(Assignee)

Comment 1

4 years ago
Created attachment 8362933 [details] [diff] [review]
0001-Bug-957421-Keep-FxA-pref-names-consistent.patch

This patch renames firefox.accounts.remoteUrl to identity.fxaccounts.remote.uri.

Asking Mark for review of the browser parts and Nick for the Android parts.

This patch only changes the pref names for browser/base/content/test/general/browser_aboutAccounts.js but I also converted line endings from CRLF to LF.
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Attachment #8362933 - Flags: review?(nalexander)
Attachment #8362933 - Flags: review?(mhammond)
(Assignee)

Comment 2

4 years ago
Comment on attachment 8362933 [details] [diff] [review]
0001-Bug-957421-Keep-FxA-pref-names-consistent.patch

Oh, and Richard for the services stuff I guess :)
Attachment #8362933 - Flags: review?(rnewman)
Comment on attachment 8362933 [details] [diff] [review]
0001-Bug-957421-Keep-FxA-pref-names-consistent.patch

Review of attachment 8362933 [details] [diff] [review]:
-----------------------------------------------------------------

r+ for me.  Android about:accounts is going the way of the dodo soon.
Attachment #8362933 - Flags: review?(nalexander) → review+
Comment on attachment 8362933 [details] [diff] [review]
0001-Bug-957421-Keep-FxA-pref-names-consistent.patch

Review of attachment 8362933 [details] [diff] [review]:
-----------------------------------------------------------------

Note for someone motivated: these prefs should really be documented on a wiki page somewhere, so that we have some docs to get stale and mislead others.
Attachment #8362933 - Flags: review?(rnewman) → review+
Comment on attachment 8362933 [details] [diff] [review]
0001-Bug-957421-Keep-FxA-pref-names-consistent.patch

Review of attachment 8362933 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for the delay!
Attachment #8362933 - Flags: review?(mhammond) → review+
(Assignee)

Comment 6

4 years ago
https://hg.mozilla.org/integration/fx-team/rev/088a4bf454a9
https://hg.mozilla.org/mozilla-central/rev/088a4bf454a9
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Duplicate of this bug: 960334
You need to log in before you can comment on or make changes to this bug.