3g.163.com sends WAP page

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 months ago

People

(Reporter: hallvors, Assigned: Peipei Cheng (needinfo if you need my action), Mentored)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form][wap][serversniff][country-cn][sitewait], URL)

(Reporter)

Description

5 years ago
Site: http://3g.163.com/news/special/136/junshiindex.html
3g.163.com sends WAP page

:: Steps To Reproduce

3g.163.com sends text/vnd.wap.wml content

:: Expected Result

Mobile site

:: Actual Result

WAP site

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][wap][serversniff][country-cn][contactready]

Comment 1

5 years ago
Safari   iOS iPod   Mobile content (rich, redirection to /touch/)
Whiteboard: [mobile-compat-form][wap][serversniff][country-cn][contactready] → [mobile-compat-form][wap][serversniff][country-cn][contactready][mentor=astevenson]

Comment 2

4 years ago
Adding the more general Bug about WAP issues for Chinese Web sites.
Depends on: 997668

Updated

4 years ago
Assignee: nobody → yliu
Status: NEW → ASSIGNED

Updated

4 years ago
Mentor: astevenson
Whiteboard: [mobile-compat-form][wap][serversniff][country-cn][contactready][mentor=astevenson] → [mobile-compat-form][wap][serversniff][country-cn][contactready]
(Reporter)

Comment 3

4 years ago
Loading 163.com directly on Firefox OS now takes me to 3g.163.com/x/ - this is a non-wap, but simplified mobile site. Firefox on Android gets a fancier touch site. The WAP problem on the URL specified here is still there, but I'm not sure if it's significant - if you can't reach such a URL from the main page during normal browsing it isn't.

Comment 4

4 years ago
We have already contacted 163. They are working on this website.
Whiteboard: [mobile-compat-form][wap][serversniff][country-cn][contactready] → [mobile-compat-form][wap][serversniff][country-cn][sitewait]
Assignee: yliu → pcheng

Comment 5

2 years ago
In accordance to https://groups.google.com/d/msg/mozilla.compatibility/OHsR590ExWs/W3ohc41tFAAJ
Requalifying the bug, the issue is happening on Firefox Android too.
OS: Gonk (Firefox OS) → Android
I think... this might be fixed now. The original URL is 404, and if you visit 163.com in Fennec, you get redirected to 3g.163.com/touch/, just like in Chrome Mobile. Thanks everyone.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.