java crash when libjavaplugin_oji.so cp'd instead of ln'd

RESOLVED INVALID

Status

Core Graveyard
Java: OJI
--
major
RESOLVED INVALID
17 years ago
7 years ago

People

(Reporter: David Kelly, Assigned: James.Melvin)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [jpibug])

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

I've recently upgraded from jre to jdk. When I did the installation, I  ran 'cp
/usr/java/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so
/usr/local/mozilla/plugins'. Then everytime I ran a java applet, mozilla would
crash. I have a talkbalk enabled version of mozilla, but whenever it would
crash, mozilla would only crash and not bring up the feedback info like usual
(this in itself could be registered as a bug).

Mozilla crashes only when the .so file is cp'd instead of ln'd into
/usr/local/mozilla/plugins. Not a huge problem or anything, but I thought I
would register it in case anyone else runs into something similar.


Reproducible: Always
Steps to Reproduce:
1.cp /usr/java/jdk1.3.1/jre/plugin/i386/ns600/libjavaplugin_oji.so
/usr/local/mozilla/plugins
2. open java.sun.com in mozilla
3. crash

I don't think it's relevent to the bug, but just in case, the system is running
redhat linux 7.1 with SGI's XFS patch.

Updated

17 years ago
Severity: minor → critical
Keywords: crash

Comment 1

17 years ago
Confirming.
Probably a dupe, though.
Severity: critical → major
Status: UNCONFIRMED → NEW
Component: Java-Implemented Plugins → OJI
Ever confirmed: true

Comment 2

17 years ago
Same behavior with 0.9.3 under RH 6.2 linux:
Mozilla crashed with message in console: 
 INTERNAL ERROR on Browser End: Exec of "java_vm" failed: 2
<
System error?:: No such file or directory

More serious: Try to cp, start browser and then
open console via Tools->Java Console.
Then Current screen will be locked and you need to kill mozilla from other
machine to unlock it.


Comment 3

17 years ago
Reassign to Ed Burns - OJI owner to make decision
Assignee: idk → edburns

Comment 4

17 years ago
Bugtraq bug 4493451
Assignee: edburns → James.Melvin
Whiteboard: [jpibug]

Comment 5

17 years ago
bug in JPI not mozilla.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Updated

7 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.