Empty input not being checked for in sync web login

RESOLVED DUPLICATE of bug 872814

Status

Cloud Services
Server: Account Portal
RESOLVED DUPLICATE of bug 872814
4 years ago
4 years ago

People

(Reporter: omar.ferrer.uprm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206152142

Steps to reproduce:

First make sure you are not logged in to Sync.

Go to:
https://account.services.mozilla.com/

Without inputting anything to any text field press "Login" button


Actual results:

Shows ambiguous general error message.  Specifically:

Oh dear.

Looks like one of the dinosaurs escaped again. We keep them away from the data, so that should be safe.

Please try again later when we've wrestled him back onto the treadmill.

If you want to report a sighting, please make sure to use their id tag: 659c3b64bcab5c26e72efe3dff8ea81e. Thanks!



Expected results:

There could be have been at least client-side checking for empty field on both text fields, along with a more specific response from the backend.
Thanks for the report.  I think this is another instance of Bug 872814. Unfortunately any fix will have to wait until after impending sync updates for FF29 which are our team's top priority at the moment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 872814
You need to log in before you can comment on or make changes to this bug.