Closed Bug 957517 Opened 6 years ago Closed 4 years ago

smart.mail.163.com - some odd rendering on login page

Categories

(Web Compatibility :: Mobile, defect, P2)

All
Android
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hsteen, Assigned: angelc04, Mentored)

References

()

Details

(Whiteboard: [mobile-compat-form][webkitcss][country-cn][sitewait])

Attachments

(2 files)

Site: http://smart.mail.163.com
smart.mail.163.com - some odd rendering on login page

:: Steps To Reproduce

1. login button lacks background styling
2. fields have different background in Android stock browser

:: Expected Result

Same layout as other browsers

:: Actual Result

differences

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][webkitcss][country-cn][contactready]
Attached file smart.mail.163.com.txt
CSS issues listed here should be fixed - some of them seem relevant
(Marking this P2 because AFAIK 163.com is quite big - we should also investigate the logged-in pages)
Priority: -- → P2
Whiteboard: [mobile-compat-form][webkitcss][country-cn][contactready] → [mobile-compat-form][webkitcss][country-cn][contactready][mentor=astevenson]
Hallvord, There are still issues, though the automated testing says it is fixed.
Flags: needinfo?(hsteen)
I have been working on this test.. It now gives the expected result when ran locally, let's see what happens after next test run..
Flags: needinfo?(hsteen)
Assignee: nobody → yliu
Status: NEW → ASSIGNED
Mentor: astevenson
Whiteboard: [mobile-compat-form][webkitcss][country-cn][contactready][mentor=astevenson] → [mobile-compat-form][webkitcss][country-cn][contactready]
Hallvord, The test is too optimistic.
Flags: needinfo?(hsteen)
Hm.. I'm getting confused. This bug and associated test apparently is for Firefox OS, but Fx OS now gets the desktop version of the login page. Looks like changes on their side - I'm quite sure I saw the problem when I worked on this test earlier.. :-/

Anyway, a new bug is required for the sniff/desktop issue. I'll move this bug to Android and keep it for handling the CSS issues.
Flags: needinfo?(hsteen)
OS: Gonk (Firefox OS) → Android
Hardware: Other → All
Blocks: 1035141
We have already contacted 163. They are working on this website.
Whiteboard: [mobile-compat-form][webkitcss][country-cn][contactready] → [mobile-compat-form][webkitcss][country-cn][sitewait]
This site will be directed to mail.163.com which is a desktop site now.
Assignee: yliu → pcheng
(In reply to Peipei Cheng from comment #8)
> This site will be directed to mail.163.com which is a desktop site now.

please ignore comment 8. I was testing ffos.

On Android, this website returns correct web page now.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
seems the login panel still have different background with default android browser.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
fixed by layout.css.prefixes.webkit;true
Status: REOPENED → RESOLVED
Closed: 5 years ago4 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.