Closed Bug 957533 Opened 7 years ago Closed 7 years ago

GenerationalGC: createArray/createObject should be able to allocate dynamic slots in the nursery

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 966040

People

(Reporter: h4writer, Unassigned)

References

(Blocks 1 open bug)

Details

Currently createArray and createObject allocate dynamic slots always using malloc, instead of nursery allocate when possible. The problem here is that we create the slots before creating the object, because we don't want invalid slots after the creation of the object/array if the slot allocation fails.

This causes the speed discrepancy between ggc and current on octane2.0-regexp.
Are there already ideas on what the best solution for this would be?
Blocks: 806646
Whoops! I totally forgot about this bug when I opened bug 966040 about the specific issue of the dynamic slots that MatchObject allocates. The solution I have implements this though, so duping to the bug where I already have patches.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966040
You need to log in before you can comment on or make changes to this bug.