"Restore Default set" adds the duplicate icons to "Customize tool bar"

RESOLVED DUPLICATE of bug 579151

Status

()

Toolkit
Toolbars and Toolbar Customization
RESOLVED DUPLICATE of bug 579151
4 years ago
4 years ago

People

(Reporter: svbabukumar, Unassigned)

Tracking

28 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox27 affected, firefox28 affected, firefox29 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8357085 [details]
Duplicate_icons.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.72 Safari/537.36

Steps to reproduce:

Step 1: Open Aurora browser (B 28)
Step 2: Click on the View --> Toolbars-->Customize
Step 3: In the opened dialogue box select the icons Separator, Flexible space and Space and drag and drop to the tool bar (Repeat step 3 more than 2 time)
Step 4: Now you can see the icons separator, Flexible Space and Space 3 times in the tool bar
Step 5: Click on the "Done" button of the Customize tool bar
Step 6: Click on the View --> Toolbar --> customize and click on the "Restore Default set" in the Customize tool bar popup


Actual results:

Clicking "Restore default set" restores all customize icons added to the tool bar and displays duplicate icons (Separators, Flexible Space and space more than 3 times) in the customize tool pop up


Expected results:

All icons should be removed from the tool bar and should display each icon only once in the custoomize icons box

Comment 1

4 years ago
Reproducible on:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (20140106141415)
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (20140109004001)

Not applicable on (Australis changed the customization options):
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (20140109030203)
Status: UNCONFIRMED → NEW
status-firefox27: --- → affected
status-firefox28: --- → affected
status-firefox29: --- → unaffected
Component: Untriaged → Toolbars and Toolbar Customization
Ever confirmed: true
Product: Firefox → Toolkit

Comment 2

4 years ago
This had happened in the past and was fixed. I'm adding the regression keyword.
Keywords: regression, regressionwindow-wanted

Comment 3

4 years ago
Dupe Bug 579151?

Comment 4

4 years ago
> Dupe Bug 579151?
Yeah. I forgot it was never fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 579151
You need to log in before you can comment on or make changes to this bug.