numbers in place of "signout"

RESOLVED FIXED

Status

Webmaker
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: pollti, Assigned: pomax)

Tracking

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

5 years ago
Created attachment 8357171 [details]
mozillaWebmaker (error on top right)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I logged in to Webmaker by Personas.


Actual results:

I see numbers in place of "signout"


Expected results:

It should look normal ;-)
(Reporter)

Updated

5 years ago
OS: All → Windows 7
Hardware: All → x86_64
(Reporter)

Comment 1

5 years ago
Created attachment 8357172 [details]
mozillaWebmakerErrorZoom
(Assignee)

Comment 2

5 years ago
This looks like the image hash for the gravatar image for when you log in, can you reproduce this reliably? (e.g. does it happen every time? If so, would you be able to check the HTML structure for that to see whether it's in an <img> or is plain text?)
Assignee: nobody → pomax
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 3

5 years ago
Created attachment 8361154 [details]
img tag for bug

Yes your right! It's an <img> and links to the gravator as in the picture.
How can I change that?
Flags: needinfo?
(Reporter)

Comment 4

5 years ago
The problem doesn't exist when I add a picture at gravatar.com for the e-mail-adress I use there.
Flags: needinfo?
(Assignee)

Comment 5

5 years ago
Created attachment 8366101 [details]
Capture.PNG

hm, when there is no image available, it should fall back to a default avatar image. When I load up webmaker (I don't use gravatar), the img element contains this:

<img src="https://secure.gravatar.com/avatar/LARGEHEXADEXIMALSTRING?s=26&amp;d=https%3A%2F%2Fstuff.webmaker.org%2Favatars%2Fwebmaker-avatar-44x44.png" alt="SAMELARGEHEXADEXIMALSTRING">

When you load up the site and login, do you get a similar image element, or are there differences in the URL it's trying to load? If the image 404s, that would explain the "alt" text showing up.
(Reporter)

Comment 6

5 years ago
When I delete my Gravatar-image now I also see the image you just uploaded. Sorry, it's unreproducible for me now.
Thanks Tim, I'm going to close this.  If we see it again, let's get a new bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

4 years ago
I have the problem again now.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 9

4 years ago
are the steps to reproduce the same?

ccing jbuck and cade since new auth should have fixed it.
(Reporter)

Comment 10

4 years ago
Yes, the steps are the same. It doesn't happen every time and when it happens, they normally disappear after one second (but not always).
Looks like this can happen when the image fails to load and it displays the alt attribute instead of the image src. Pomax suggested making the alt tag a blank string, which should do the trick!
(Reporter)

Comment 12

4 years ago
Yes, I think that would be better ;)
(Assignee)

Comment 13

4 years ago
I already did this for the login update for Thimble, I'll effect that change for the other apps as well.
(Assignee)

Comment 14

4 years ago
Created attachment 8389380 [details] [review]
https://github.com/mozilla/webmaker.org/pull/628

fix for webmaker.org
Attachment #8389380 - Flags: review?(jon)

Updated

4 years ago
Attachment #8389380 - Flags: review?(jon) → review+

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.