Closed Bug 957707 Opened 6 years ago Closed 6 years ago

HTTP cache v2: merge management thread and IO thread, new MANAGEMENT level

Categories

(Core :: Networking: Cache, defect)

Other Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: mayhemer, Assigned: mayhemer)

References

Details

Attachments

(1 file, 3 obsolete files)

During shutdown we race IO thread and management thread (memory purging).  There is a risk of static vars mt access and keeping stuff alive after IO manager is shutdown.  Also, since the memory pool management is a very low priority stuff to do and we now have two threads regarding the new cache, I think it's an unnecessary luxury.

We only must prevent nearly empty (no-op) loops when the pool is large and over the limit but there is by accident nothing or very little to purge.  Triggering purge only when over a limit+threshold might do the trick.
Depends on: 958311
Attached patch wip1 - backup (obsolete) — Splinter Review
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Duplicate of this bug: 958311
Comment on attachment 8359784 [details] [diff] [review]
wip1 - backup

Causes Assertion failure: progress <= progressMax (unexpected progress values), at ../../../../netwerk/protocol/http/nsHttpChannel.cpp:5413
TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_bug495300.html
Depends on: 958317
Attached patch wip2 (obsolete) — Splinter Review
https://tbpl.mozilla.org/?tree=Try&rev=29d9580d7a53
Attachment #8359784 - Attachment is obsolete: true
Comment on attachment 8361365 [details] [diff] [review]
wip2.1 [unstable]

Still causes Assertion failure: progress <= progressMax 
https://tbpl.mozilla.org/php/getParsedLog.php?id=33167617&tree=Try
Attachment #8361365 - Attachment description: wip2.1 → wip2.1 [unstable]
Depends on: 961140
Attached patch v1 (stable)Splinter Review
https://tbpl.mozilla.org/?tree=Try&rev=7c1d1ca3f804 (with bug 958311)
Attachment #8361365 - Attachment is obsolete: true
Attachment #8363262 - Flags: review?(michal.novotny)
Attachment #8363262 - Flags: review?(michal.novotny) → review+
https://hg.mozilla.org/mozilla-central/rev/8624d24dbe67
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.