[B2G][Gaia] Ability to get the keyboard to appear in places where keyboard is useless and unnecessary

RESOLVED DUPLICATE of bug 937487

Status

Firefox OS
Gaia::System::Input Mgmt
RESOLVED DUPLICATE of bug 937487
4 years ago
4 years ago

People

(Reporter: croesch, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.2 affected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8357331 [details]
Keyboard over Camera app

When the user is in a program such as Contacts, if the user is in the Add a Contact page and they quickly tap the name field then tap add picture, the user can see the keyboard if they go to take a photo for the contact or go to the Gallery. This issue can happen anywhere where a user can quickly tap a text field then a drop down menu or that takes you to a new page within an app.

Repro Steps:
1) Updated Buri to Build ID: 20140106004001
2) Launch the Contacts app.
3) Tap on the Add Contact button.
4) Quickly tap in the name field then in the Add Picture button.
5) Choose to go to the gallery or take a photo.
6) Notice that the keyboard appears on the gallery or photo page.

Actual:
Keyboard is populating areas where it should not when quick tapping in text fields then drop down boxes or buttons that navigate away.

Expected:
Keyboard should only populate in areas designated for keyboard functionality.

Environmental Variables
Device: Buri v 1.3.0 Moz RIL
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a43cb4b322d3
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Platform Version: 28.0a2


Notes:
Repro frequency: 3/4 75%

See Attached: Screenshot

Was also able to get this to happen in Email when tapping on a text field then quickly tapping on a drop down box. The keyboard would appear over the drop down box.
(Reporter)

Comment 1

4 years ago
This issue also occurs on the latest Buri v 1.2.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/d552c08a72d0
Gaia: 8441587c3b352e052fee07665c21fd192540f19f
Platform Version: 26.0
(Reporter)

Comment 2

4 years ago
I was Unable to repro in V1.1

Updated

4 years ago
Component: Gaia → Gaia::Keyboard
This feels a bit edge casey - I'd imagine a user could recover from this easily if need be.

Updated

4 years ago
Keywords: regression
I think this is the same issue as Bug 937487.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: Gaia::Keyboard → Gaia::System::Input Mgmt
Resolution: --- → DUPLICATE
Duplicate of bug: 937487
You need to log in before you can comment on or make changes to this bug.