hotmail.com / mail.live.com / login.live.com sends desktop content to Firefox OS

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: hallvors, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-compat-form][serversniff][country-all][sitewait], URL)

(Reporter)

Description

5 years ago
Site: http://www.hotmail.com
hotmail.com / mail.live.com sends desktop content to Firefox OS

:: Steps To Reproduce

We get the desktop UI.
Bug 759111 has regressed on their side (but only for Fx OS, Android version seems OK)

:: Expected Result

Mobile site

:: Actual Result

Desktop site

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][serversniff][country-all][contactready]
(Assignee)

Comment 1

5 years ago
So I'm trying to contact a few persons at Microsoft. It's usually hard to get a quick answer and even harder to get a timely resolution.
Assignee: nobody → kdubost
Status: NEW → ASSIGNED
Hardware: Other → ARM
(Assignee)

Comment 2

5 years ago
Someone from Microsoft is trying to provide me with the right contact information.
(Assignee)

Comment 3

5 years ago
Ongoing. The person is digging for information.
(Assignee)

Comment 4

5 years ago
Good progress. Communicated the UA strings documentation for Firefox OS.

    Mozilla/5.0 (Mobile; rv:$VERSION) Gecko/$VERSION Firefox/$VERSION

https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference#Firefox_OS
(Assignee)

Updated

5 years ago
Whiteboard: [mobile-compat-form][serversniff][country-all][contactready] → [mobile-compat-form][serversniff][country-all][sitewait]
(Assignee)

Comment 5

5 years ago
So Microsoft replied.

> Thanks, Karl. I've opened a bug on our end to send Firefox OS logins to the proper mobile experience.
> 
> I don't have a set fix date to broadcast, but rest assured that it is in our queue.
(Reporter)

Updated

4 years ago
Duplicate of this bug: 974861
(Assignee)

Updated

4 years ago
See Also: → bug 621638
(Reporter)

Updated

4 years ago
Summary: hotmail.com / mail.live.com sends desktop content to Firefox OS → hotmail.com / mail.live.com / login.live.com sends desktop content to Firefox OS
(Reporter)

Comment 7

4 years ago
And now they did fix it indeed - the "forward URL" in the query string for the login page now has a pathname starting with the /m/ for mobile, which was missing earlier. Yay!
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.