All users were logged out of Bugzilla on October 13th, 2018

Preloading contacts in a SIM customization does not work anymore

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: jsmith, Assigned: albert)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Reporter)

Description

5 years ago
Build - 1/8/2014 Buri 1.3

STR

1. Follow the steps here - https://wiki.mozilla.org/B2G/QA/Customizations#Build_Setup to setup your customized build with an AT&T US SIM
2. After completing the FTE, launch the contacts app

Expected

There should be four contacts present - test 1, test 2, 310410 person, and Inf 310410.

Actual

There is only two contacts present - test 1, test 2. This implies that the SIM customized contacts failed to be preloaded.
(Reporter)

Updated

5 years ago
blocking-b2g: --- → 1.3?
Keywords: regression
triage: 1.3+ regression
blocking-b2g: 1.3? → 1.3+
hi Yuren, wonder if you have some insight into this? Thanks
Flags: needinfo?(yurenju.mozilla)
Is there anything about contacts in the logcat?
(Assignee)

Comment 4

5 years ago
I think this bug and 957866 are caused by bug 952922, I will review build dependencies.
(Reporter)

Updated

5 years ago
Blocks: 952922
(Reporter)

Updated

5 years ago
No longer blocks: 952922
This is a part of customization mechanism of variant.json. Albert, could you help on this issue?
Flags: needinfo?(yurenju.mozilla) → needinfo?(acperez)
(Assignee)

Updated

5 years ago
Assignee: nobody → acperez
Flags: needinfo?(acperez)
(Assignee)

Comment 6

5 years ago
From logcat:

E/GeckoConsole( 1401): [JavaScript Error: "TypeError: 'type' member of ContactField can't be converted to a sequence." {file: "app://communications.gaiamobile.org/ftu/js/customizers/default_contacts_customizer.js" line: 7}]

Error when creating contact -> var contact = new mozContact(contacts[i]);


The format of attus_contacts.json is wrong, the attribute 'type' should be an array instead of string.
Modifying "type": "Other" by "type": ["Other"] fix the problem.
(Reporter)

Comment 8

5 years ago
(In reply to Albert [:albert] from comment #6)
> From logcat:
> 
> E/GeckoConsole( 1401): [JavaScript Error: "TypeError: 'type' member of
> ContactField can't be converted to a sequence." {file:
> "app://communications.gaiamobile.org/ftu/js/customizers/
> default_contacts_customizer.js" line: 7}]
> 
> Error when creating contact -> var contact = new mozContact(contacts[i]);
> 
> 
> The format of attus_contacts.json is wrong, the attribute 'type' should be
> an array instead of string.
> Modifying "type": "Other" by "type": ["Other"] fix the problem.

That's not right. This is exact format worked fine on 1.2, so this is a regression in format parsing on 1.3.
Flags: needinfo?(jsmith)
(Assignee)

Comment 9

5 years ago
(In reply to Jason Smith [:jsmith] from comment #8)
> (In reply to Albert [:albert] from comment #6)
> > From logcat:
> > 
> > E/GeckoConsole( 1401): [JavaScript Error: "TypeError: 'type' member of
> > ContactField can't be converted to a sequence." {file:
> > "app://communications.gaiamobile.org/ftu/js/customizers/
> > default_contacts_customizer.js" line: 7}]
> > 
> > Error when creating contact -> var contact = new mozContact(contacts[i]);
> > 
> > 
> > The format of attus_contacts.json is wrong, the attribute 'type' should be
> > an array instead of string.
> > Modifying "type": "Other" by "type": ["Other"] fix the problem.
> 
> That's not right. This is exact format worked fine on 1.2, so this is a
> regression in format parsing on 1.3.

Anyway, is not a problem of single variant, the problem is with contacts API.
(Reporter)

Comment 10

5 years ago
Reuben - Was the syntax change in the Contacts API intentional above?
Flags: needinfo?(reuben.bmo)
Yes. 'type' was always an array, but we only started enforcing it on 1.3 :(
Flags: needinfo?(reuben.bmo)
(Reporter)

Comment 12

5 years ago
Okay - that makes this invalid then. I just patched the customization to use an array instead.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.