"Assertion failure: !aIID.Equals((::nsISupports::COMTypeInfo<int>::kIID))" with WakeLock, XPathEvaluator

VERIFIED FIXED in mozilla29

Status

()

Core
DOM
--
critical
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Assigned: baku)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
mozilla29
x86_64
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8357529 [details]
testcase

Assertion failure: !aIID.Equals((::nsISupports::COMTypeInfo<int>::kIID))

Is this bug 798188 again?

Regression from http://hg.mozilla.org/mozilla-central/rev/9fc62be40607#l16.1 ?
(Reporter)

Comment 1

4 years ago
Created attachment 8357530 [details]
stack
> Is this bug 798188 again?

Actually, no.

This is bug 952079 having this line in the diff:

>-  NS_INTERFACE_MAP_ENTRY_AMBIGUOUS(nsISupports, nsIDOMMozWakeLock)

And not replacing it with anything else, so this class no longer QIs to nsISupports.  Which is exactly what the assert is about, so it's working!
Assignee: nobody → amarchesini
tracking-firefox29: --- → ?
Component: XPCOM → DOM
(Assignee)

Comment 3

4 years ago
Created attachment 8357644 [details] [diff] [review]
wl.patch
Attachment #8357644 - Flags: review?(bzbarsky)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 957893
Attachment #8357644 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 5

4 years ago
https://tbpl.mozilla.org/?tree=Try&rev=05c99e39f73c

https://hg.mozilla.org/integration/mozilla-inbound/rev/6a34631f0c41
https://hg.mozilla.org/mozilla-central/rev/6a34631f0c41
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Updated

4 years ago
tracking-firefox29: ? → ---
tracking-firefox29: --- → -
tracking-firefox29: - → ---
Reproduced 2014-01-08-mozilla-central-debug, Mac OS X 10.9.
Verified fixed 29.0a1 2014-01-13-mozilla-central-debug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.