Minimizing the browser triggers a reflow

VERIFIED DUPLICATE of bug 639

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 639
19 years ago
19 years ago

People

(Reporter: rbs, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When cliking on the minimize button, it is observed that an
unecessary reflow operation is triggered.

I can understand that the reflow is necessary to reconstruct
the window when clicking on the taskbar entry to *re-open* the
browser window.

But I am failing to understand why a reflow should be done when
minimizing the window given that there is no rendering aftewards.
By getting rid of the unecessary reflow, the minimization will be
instantaneous, no matter how large the document is.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
I think these are the same ...

*** This bug has been marked as a duplicate of 639 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.