Closed Bug 957918 Opened 6 years ago Closed 6 years ago

Port chat/ changes from Instantbird to comm-central - 7

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 29.0

People

(Reporter: clokep, Assigned: clokep)

References

()

Details

Attachments

(2 files, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #920801 +++

Instantbird and comm-central's chat/ folders have diverged again. Time for another sync/

Bug 955627 - Overly greedy regexp butchers topic on LIST responses, r=clokep.
Bug 955575 - JS-Yahoo: Yahoo! Mobile status not taken into account, r=clokep,Mic.
Bug 955648 - Max length is incorrect for MONITOR, r=aleth.
Bug 955599 - Bustage fix for Yahoo tests, r=fqueze.
Bug 955661 - Warning: Unhandled IRC message 042 and 338 when connecting to oftc.net, r=aleth.
Bug 954088 - Configurable alternate IRC nicks, r=aleth.
Bug 955569 - JS-Yahoo: "Would you like to be my chat buddy" sent on accepting buddy auth request, r=clokep.
Bug 955667 - Unhandled IRC message 263: LIST refused, r=clokep.
Bug 955672 - Use defineLazyModuleGetter instead of defineLazyGetter, r=fqueze.
Bug 955606 - IRC ping does not properly send a timestamp, r=aleth,fqueze.
Bug 955003 - Contacts added directly to "Other Contacts" don't show until collapsed/expanded, r=fqueze.
Bug 955537 - Ensure that commands that only work in channels use CONTEXT_CHAT, r=aleth.
Bug 955522 - JS-Yahoo: No handler for Yahoo! packet 83, r=clokep.
Bug 955623 - this._account socket error on disconnect [regression], r=clokep.
Bug 955671 - Awesometab fails when you change the protocol being used in a conversation, r=fqueze.
Bug 955676 - Don't handle incoming data synchronously, r=clokep,fqueze.
Bug 955621 - JS Error when reordering buddies inside a contact, r=fqueze.
Bug 955671 - Follow-up to fix shutdown error / unit test bustage, r=bustage-fix.
Bug 955030 - RTL messages on the receiver side, r=fqueze.
Bug 955420 - Default normalizedName normalization is too aggressive, r=clokep.
Bug 954887 - Add explanatory comments to document normalizedNames, r=fqueze,clokep.
Bug 955121 - Show participant tooltip when hovering nick in conversation, r=fqueze.
Bug 955700 - Accounts stuck in the "Connecting…" state, r=fqueze,clokep.
Bug 955553 - Provide a way to obtain the normalizedName of a nick, r=clokep,fqueze.
Bug 955553 - Provide a way to obtain the normalizedName of a nick, add imAccount implementation, r=aleth.
Bug 955587 - Remove VKontakte protocol, r=fqueze.
Bug 955711 - Buddy disappears when detached in the Other Contacts tag, r=fqueze.
Bug 955655 - Stats ids are not set consistently, r=fqueze.
Bug 955703 - Open conversations when joinChat is called for better responsiveness, r=clokep.
Bug 955720 - Fix up Yahoo strings, r=fqueze.
Bug 955734 - this._account is undefined on connection reset, r=clokep.
Bug 955708 - JS-Yahoo: Shutdown error: this._keepAliveTimer is undefined, r=clokep,aleth.

This should be the last merge before bug 956609 lands.
It looks like only two bugs touch the UI:
Bug 955030 - RTL messages on the receiver side, r=fqueze.
This touches instantbird/themes, maybe aleth can take a look at this?

Bug 955121 - Show participant tooltip when hovering nick in conversation, r=fqueze.
This is being ported in bug 956579.
Blocks: 956579
Flags: needinfo?(aleth)
Attached patch Port 32 changesets (obsolete) — Splinter Review
Florian, could you take a look over this real quick and make sure nothing crazy is being done? My build has not yet finished with these, but I wanted to upload this patch before going to bed.
Attachment #8357581 - Flags: review?(florian)
Comment on attachment 8357581 [details] [diff] [review]
Port 32 changesets

(In reply to Patrick Cloke [:clokep] from comment #1)
> It looks like only two bugs touch the UI:
> Bug 955030 - RTL messages on the receiver side, r=fqueze.
> This touches instantbird/themes,

It looks to me like we modified the simple theme because ib-msg-txt was no longer a suitable class to generate content with the :before/:after pseudo class. So this shouldn't need any change in the Tb UI.

> maybe aleth can take a look at this?

Of course I would be happy to have a second opinion :).


> Bug 955121 - Show participant tooltip when hovering nick in conversation,
> r=fqueze.
> This is being ported in bug 956579.

I think it would be better to finish bug 956579 (looks like it's only blocked on our reviews) and skip this changeset in the chat/ merge.


(In reply to Patrick Cloke [:clokep] from comment #2)
> Created attachment 8357581 [details] [diff] [review]
> Port 32 changesets
> 
> Florian, could you take a look over this real quick and make sure nothing
> crazy is being done?

This all looks reasonable, but I only looked quickly.

> My build has not yet finished with these,

Please push this to the try server; I don't want us to bust the Tb tree again for silly reasons ;).

> I wanted to upload this patch before going to bed.

Thanks!
Attachment #8357581 - Flags: review?(florian) → review+
(In reply to Florian Quèze [:florian] [:flo] from comment #3)
> Comment on attachment 8357581 [details] [diff] [review]
> Port 32 changesets
> 
> (In reply to Patrick Cloke [:clokep] from comment #1)
> > It looks like only two bugs touch the UI:
> > Bug 955030 - RTL messages on the receiver side, r=fqueze.
> > This touches instantbird/themes,
> 
> It looks to me like we modified the simple theme because ib-msg-txt was no
> longer a suitable class to generate content with the :before/:after pseudo
> class. So this shouldn't need any change in the Tb UI.

OK. Thanks for looking at this.

> > Bug 955121 - Show participant tooltip when hovering nick in conversation,
> > r=fqueze.
> > This is being ported in bug 956579.
> 
> I think it would be better to finish bug 956579 (looks like it's only
> blocked on our reviews) and skip this changeset in the chat/ merge.

I've removed this changeset from the patch.

> (In reply to Patrick Cloke [:clokep] from comment #2)
> > Created attachment 8357581 [details] [diff] [review]
> > Port 32 changesets
> > 
> > Florian, could you take a look over this real quick and make sure nothing
> > crazy is being done?
> 
> This all looks reasonable, but I only looked quickly.

Thanks.

> > My build has not yet finished with these,
> 
> Please push this to the try server; I don't want us to bust the Tb tree
> again for silly reasons ;).

Will do.
Attachment #8357581 - Attachment is obsolete: true
Attachment #8357726 - Flags: review+
https://hg.mozilla.org/comm-central/rev/f19623bc19a4
https://hg.mozilla.org/comm-central/rev/5ca9c32c86b0
https://hg.mozilla.org/comm-central/rev/355a62935a44
https://hg.mozilla.org/comm-central/rev/1ebfad4f3c62
https://hg.mozilla.org/comm-central/rev/98d52441b2bb
https://hg.mozilla.org/comm-central/rev/90a9432fa20a
https://hg.mozilla.org/comm-central/rev/41222a7998ed
https://hg.mozilla.org/comm-central/rev/146cbcce89e5
https://hg.mozilla.org/comm-central/rev/cd1951a166ba
https://hg.mozilla.org/comm-central/rev/3441ad6a11d6
https://hg.mozilla.org/comm-central/rev/ac862ddf83a1
https://hg.mozilla.org/comm-central/rev/0a0283eb485b
https://hg.mozilla.org/comm-central/rev/6ecb18d9226e
https://hg.mozilla.org/comm-central/rev/4647dbea9a08
https://hg.mozilla.org/comm-central/rev/68b591988493
https://hg.mozilla.org/comm-central/rev/5179bcfa7ed5
https://hg.mozilla.org/comm-central/rev/6a78de7882a4
https://hg.mozilla.org/comm-central/rev/e869c1947d4b
https://hg.mozilla.org/comm-central/rev/2b7baea71ce3
https://hg.mozilla.org/comm-central/rev/5761c271a566
https://hg.mozilla.org/comm-central/rev/40b9e93fc824
https://hg.mozilla.org/comm-central/rev/d6d29a5b93f8
https://hg.mozilla.org/comm-central/rev/61c749cdb7ee
https://hg.mozilla.org/comm-central/rev/9e85476447c4
https://hg.mozilla.org/comm-central/rev/1df70105f724
https://hg.mozilla.org/comm-central/rev/14b7d6c3943c
https://hg.mozilla.org/comm-central/rev/377fa3ca3c6c
https://hg.mozilla.org/comm-central/rev/5254fe2f869b
https://hg.mozilla.org/comm-central/rev/1b7f677bf704
https://hg.mozilla.org/comm-central/rev/3e51cee75e69
https://hg.mozilla.org/comm-central/rev/232b82d14cff
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(aleth)
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 29.0
Attached patch Port 1 changesetSplinter Review
I messed up and missed a changeset to port, this is:
Bug 955599 - Port |Bug 884319 - Add http.jsm to toolkit for usage by Thunderbird FileLink, Lightning and Instantbird|, update YMSG to use new API, r=qheaden.
Attachment #8357980 - Flags: review+
(In reply to Patrick Cloke [:clokep] from comment #7)
> Created attachment 8357980 [details] [diff] [review]
> Port 1 changeset
> 
> I messed up and missed a changeset to port, this is:
> Bug 955599 - Port |Bug 884319 - Add http.jsm to toolkit for usage by
> Thunderbird FileLink, Lightning and Instantbird|, update YMSG to use new
> API, r=qheaden.

https://hg.mozilla.org/comm-central/rev/643ded75fc33
Blocks: 962035
You need to log in before you can comment on or make changes to this bug.