Closed Bug 957960 Opened 6 years ago Closed 5 years ago

m.hongshu.com navigation rendering broken due to -webkit- CSS for flexbox

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: hsteen, Assigned: yliu)

References

()

Details

(Whiteboard: [mobile-compat-form][webkitcss][country-cn][contactready])

Attachments

(2 files)

Site: http://m.hongshu.com
m.hongshu.com navigation rendering broken due to -webkit- CSS for flexbox

:: Steps To Reproduce

Navigation looks wrong -see screenshot.

:: Expected Result

prettiness

:: Actual Result

-webkit-messiness

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][webkitcss][country-cn][contactready]
Attaching a report that among other things include CSS issues that need fixing - guess this one matters for the navigation:
"-webkit-box-flex used without equivalents for nav ul li in http://m.hongshu.com/img/index.css:11:12, value: 1",
The first time I see these headers in the HTML.

<meta http-equiv="mobile-agent" content="format=wml; url=http://wap.hongshu.com/">
<meta http-equiv="mobile-agent" content="format=xhtml; url=http://g.hongshu.com/">
<meta http-equiv="mobile-agent" content="format=html5; url=http://m.hongshu.com/">

Firefox Android, Firefox OS, Chrome Nexus, iOS Safari, UCWeb get redirected to g.hongshu.com

Hallvord did you find any devices which gets redirected to m.hongshu.com?
Flags: needinfo?(hsteen)
I don't remember if I did back then - I don't now.
Flags: needinfo?(hsteen)
Assignee: nobody → yliu
Status: NEW → ASSIGNED
Invalid since I don't think this server is really used anymore
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.