Page Load Fail causes view-source to render Page

RESOLVED WORKSFORME

Status

()

Core
Networking: HTTP
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Rob, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8357744 [details]
FireFox Nightly 29.0a1 (2014-01-08) - Mystery Error Message

I was viewing Pages on this Site and after I closed my Browser, and later restarted it, this Tab does not reload: http://digital.vita-technologies.com/winter2013#&pageSet=13 without an error.

Instead, I get a portion of an Error Message (ours) with a Link that does not work. The broken Link on the rendered Web Page (and rendered in the VS Window) says: "Or you can add an exception…" . I have seen other PopUps with that text BUT it also had more text about certificates, and those Links worked.

Further if I attempt to use view-source (so I could write something more useful in this Bug Report) I find that the view-source feature RENDERS the Browser's view exactly (whereas other Tab's view-source feature works as expected).

Made it a major since I can not access a Site, and this might involve Certificates.


This Bug seems limited to this one Tab/Url. I am attaching a screenshot.


(PS: Please feel free to craft a better "Summary" when you categorize this Bug).
(Reporter)

Comment 1

5 years ago
If I try to load the Page using Google Chrome I get this 'PopUp' from their Browser:

"No data received

[Reload]  [More/Less]

Unable to load the web page because the server sent no data.
Error code: ERR_EMPTY_RESPONSE"

.


Using GC's view-source (strangely) also produces a rendering that is the same as the Browser View; as opposed to a blank view-source Page (I presume that would be the correct response).


Looking at WinXp's Network it does look like 'some' Data IS being sent back as a response, whether the response it a properly formed Packet that says it is empty is something I do not know. I am not convinced that the Error Message "... server sent no data" is entirely accurate. 

"Data" is "sent" (from the Server), it is just that the Page is Empty (and OUR info PopUp does not display a proper Message, but instead displays a broken Link).


If our Message was more like GC's (with improved accuracy), IE: we could see the Message and the Link(s) worked, then I would consider this BR fixed.


Thanks.
Can you reproduce the problem again?
If yes:
Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

Or on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
Component: General → Networking: HTTP
Flags: needinfo?(rob1weld)
Product: Firefox → Core
(Reporter)

Comment 3

5 years ago
It is as though the Server "sends" index.html but the length is zero bytes, that the Page is generated might support such a premise.

That another Browser has similar trouble with whatever the trouble WAS with that Server suggests some confirmation for me. I can not do it again on the same URL since whatever issue they had was fixed. You might try to access such a file on another Server.
(Reporter)

Comment 4

5 years ago
I have tried to clear the "Needinfo" on this Page and it will not clear.

If that continues I will file a BR in a few days.
Flags: needinfo?(rob1weld)
(In reply to Rob from comment #3)
> I can not do it again on the
> same URL since whatever issue they had was fixed
Closing for now. Please reopen if you see this again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.