Closed Bug 958060 Opened 6 years ago Closed 6 years ago

[DSDS] When SIM 1 is PIN locked, there should be no Cellular Data page in FTE.

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 verified)

VERIFIED FIXED
1.3 C3/1.4 S3(31jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- verified

People

(Reporter: echu, Assigned: qdot)

Details

(Whiteboard: dsdsrun1.3-2, [systemsfe])

Attachments

(1 file)

Cellular & Data page will still show even SIM 1 is PIN locked.

* Build Number  
Fugu              
Gaia      22bc6be5b76cdc6d4e9667ff070979041a20ce2f
Gecko     cd8bc54e911470fa6519d461e5e6b3ddc8f57f5f
BuildID   20140109175226
Version   28.0a2

* Reproduce Steps
1. In FTE, skip SIM 1 PIN unlock.
2. Go to next page SIM manger, and go to next.

* Expected Result
Cellular Data page should not be seen. Because in v1.3, default outgoing data SIM is SIM 1, so if it's locked, Cellular Data page should not be seen.

* Actual Result
Cellular Data page still can be seen.

* Occurrence rate
100%
blocking-b2g: --- → 1.3?
The reason I set 1.3? is that this is not consistent with single SIM device like Buri. When SIM is locked, there is no Cellular Data page in FTE on Buri. So if anyone know the real reason why the page will not been shown in FTE for this kind of case, it will be more convincible.
Gregor,

Please help reassign.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(anygregor)
Do we have UX specs for this?
Flags: needinfo?(anygregor) → needinfo?(firefoxos-ux-bugzilla)
Carrie has the latest and complete DSDS specs. Flagging her on ni?.
Flags: needinfo?(cawang)
Flags: needinfo?(firefoxos-ux-bugzilla)
I think this depends on FTE spec.
If the single SIM will not show the Cellular & Data page while the SIM is locked, then we shouldnt show it in DSDS as well. ni? Jacqueline to confirm this. Thanks!
Flags: needinfo?(cawang) → needinfo?(jsavory)
Yes, I agree, I think it should be consistent with single SIM and not show the Cellular & Data page in DSDS when the SIM is locked. 

Carrie - can you add this to your DSDS spec?
Flags: needinfo?(jsavory) → needinfo?(cawang)
I think for this one, it's a common behavior aligns with single SIM, not a special interaction should be addressed in DSDS spec. Hence, I'd suggest dealing it as a bug and fix it base on general FTE spec. Thanks!
Flags: needinfo?(cawang)
I've been in the FTE a lot lately anyways, so I can probably get this fixed.
Assignee: nobody → kyle
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2, [systemsfe]
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
I'm having problems reproing this on a single sim phone. Since this mentioned DSDS, was the original repro done with 2 SIM cards, SIM 1 locked and the SIM 2 not locked? I can see where this would happen if that was the case.
Flags: needinfo?(echu)
Currently, if two SIMs are inserted in a phone and the secondary is the only one ready, we still show the data screen. Checking for SimManager.available() will use the MobileConnections API to make sure the default sim is in a ready state. If not, we skip the data screen.
Attachment #8368376 - Flags: review?(mhenretty)
Comment on attachment 8368376 [details] [review]
Patch 1 (v1) - Only show FTU Data screen when default sim is available

Assigning the review to Francisco who is a peer of the module.
Attachment #8368376 - Flags: review?(mhenretty) → review?(francisco.jordano)
Comment on attachment 8368376 [details] [review]
Patch 1 (v1) - Only show FTU Data screen when default sim is available

Would like to see unit tests, but won't block on that since is a 1.3+.

Thanks Kyle!
Attachment #8368376 - Flags: review?(francisco.jordano) → review+
Yeah, I actually tried working on unit tests for a while, but figuring out how to deal with DSDS in the mock sim manager was going to take longer than getting this landed before friday. I'll file a followup on it, and I'm also poking at a system to let us test things like this in integration too.
https://github.com/qdot/gaia/commit/0cfa975ecee7ddf211c626e217939350447f8ea5
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
(In reply to Kyle Machulis [:kmachulis] [:qdot] from comment #9)
> I'm having problems reproing this on a single sim phone. Since this
> mentioned DSDS, was the original repro done with 2 SIM cards, SIM 1 locked
> and the SIM 2 not locked? I can see where this would happen if that was the
> case.

Yes, SIM 2 is not locked while SIM 1 is locked. In 1.3, SIM 1 will be default outgoing voice/message/data SIM. That's one in this case Data & Cellular page should be hidden while SIM 1 is locked since it's equal to single SIM case.
Flags: needinfo?(echu)
Uplifted 0cfa975ecee7ddf211c626e217939350447f8ea5 to:
v1.3: dc617a8e425185920a894a9ffbdd5feba5d36e87
Verified.
Fugu - 
Gaia      bb36b4164d3e51ca04b612e507e1178f80bf240d
Gecko     4227240a4d3e1e418ced160c2a48cb454d7b5645
BuildID   20140204104742
Version   28.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.