Closed Bug 958170 Opened 11 years ago Closed 11 years ago

Intermittent unresponsive blank white content on about:start on startup

Categories

(Firefox for Metro Graveyard :: Firefox Start, defect, P2)

x86_64
Windows 8.1
defect

Tracking

(firefox28 fixed, firefox29 fixed)

RESOLVED FIXED
Firefox 29
Tracking Status
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: ally, Assigned: emtwo)

References

Details

(Keywords: qawanted, steps-wanted, verifyme, Whiteboard: [beta28] [defect] p=1)

Attachments

(3 files)

Attached image Screenshot (4).png
Got splash screen, followed by blank white screen, no interesting log output. Able to swipe in & use app bar, but very jarring. 

It did re-appear after killing & restarting Nightly, so might have been a one off.
Whiteboard: [triage]
Whiteboard: [triage] → [triage] [defect] p=0
This seems to be an intermittent bug; it would be great if someone can find steps to reproduce it reliably.  Maybe related to bug 957501?
Depends on: 957501
Summary: Startup on m-c today produced a white screen → Intermittent unresponsive blank white content on about:start on startup
Whiteboard: [triage] [defect] p=0 → [beta28] [defect] p=0
I just had this happen after restarting for an update, and saw the following two errors in the log on startup:

SessionRestore.init called with previous execution state 'Running'
resource://app/components/SessionStore.js:91

data.windows[windowIndex] is undefined
resource://app/components/SessionStore.js:778

Definitely a variant of bug 957501.
When this happened, sessionstore.js contained: {"windows":[]}

We should approach this two ways: First, make sure that bad sessionstore data like this does not break the UI on startup.  And, figure out how we can avoid writing bad data like this to start with.
Attached file sessionstore.bak.txt
Actually, I think this may have been the sessionstore.js file at the time of the failed startup.  It appears to contain valid window data but no "selectedWindow" property.
I think there may be two separate issues. One issue (the one Ally saw) is caused by the fact that "selectedWindow" is a property that did not initially exist in Metro's sessionstore.js. So the first time you update to include the new code that checks for it, it won't be there which is the cause of:

data.windows[windowIndex] is undefined
resource://app/components/SessionStore.js:778

I can reproduce the issue without getting the other error with SessionStore.init so I suspect they are separate issues.
Attachment #8360057 - Flags: feedback?(mbrubeck)
Attachment #8360057 - Flags: feedback?(mbrubeck) → review+
https://hg.mozilla.org/integration/fx-team/rev/b1586c7b4ebc
Assignee: nobody → msamuel
Status: NEW → ASSIGNED
Whiteboard: [beta28] [defect] p=0 → [beta28] [defect][fixed-in-fx-team] p=1
Blocks: metrov1it22
No longer blocks: metrov1backlog
Priority: -- → P2
QA Contact: jbecerra
No longer depends on: 957501
https://hg.mozilla.org/mozilla-central/rev/b1586c7b4ebc
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Whiteboard: [beta28] [defect][fixed-in-fx-team] p=1 → [beta28] [defect] p=1
Target Milestone: --- → Firefox 29
Flagging for verification but that will depend on finding steps to reproduce.
Keywords: verifyme
Hi Ally, can you add steps to reproduce to assist QA in testing.
Flags: needinfo?(ally)
Marco, I never had reproducible steps as stated in comment 0. However, Marina must have some sort of steps to test her patch, so let's ask her. :)
Flags: needinfo?(ally) → needinfo?(msamuel)
The way I tested this patch was by editing my sessionstore.js file to remove the "selectedWindow" property from it and then switching to metro. Prior to this patch, that would result in blank white content, but it should no longer do so.
Flags: needinfo?(msamuel)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: