Closed Bug 958194 Opened 6 years ago Closed 6 years ago

m.taobao.com sends a different site for Firefox OS/Firefox Android than on Android stock browser.

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 784478

People

(Reporter: rkuhlman, Unassigned)

References

()

Details

(Whiteboard: dogfood1.3 [country-cn] [serversniff] [contactready])

Attachments

(1 file)

m.taobao.com on an Android browser is not the same as m.taobao.com on Firefox OS browser. See attached screenshot for comparison.

Repro Steps:
*prerequisite: Have an android device to compare results with Buri device.
1) Updated Buri to BuildID: 20140106004001
2) Launch Browser.
3) Navigate to m.taobao.com.
4) Repeat steps 2-3 on Android device and compare results.

Actual:
m.taobao.com on Android device looks completely different than m.taobao.com on FxOS.

Expected:
The same mobile site is loaded.

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140106004001
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Gecko: a43cb4b322d3
Version: 28.0a2
Firmware Version: 20131115

Notes:

Repro frequency: 100%
See attached: screenshot.
Component: Gaia::Browser → Mobile
Product: Firefox OS → Tech Evangelism
This issue also affects 1.1 and 1.2.
1.2 Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140108004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 0d8b879ffd70
Version: 26.0
Firmware Version: 20131115

1.1 Environmental Variables
Device: Buri v 1.1.0 COM RIL 
Build ID: 20140102041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bdac595a4e46
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281
On zte device Firefox OS
and on Android Firefox

I get the same exact site with http://m.taobao.com/

The difference comes when entering http://taobao.com/ 
on Firefox android redirects to http://m.taobao.com/ (mobile)
on Firefox OS redirects to http://www.taobao.com/ (desktop)

but that is covered by "Bug 921556"


What is the user agent being tested?
with Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.taobao.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1

HTTP/1.1 200 OK
Connection: keep-alive
Content-Encoding: gzip
Content-Language: zh-CN
Content-Type: text/html;charset=UTF-8
Date: Fri, 10 Jan 2014 02:04:34 GMT
Server: nginx
Set-Cookie: imewweoriw=irPqMDi78Z5F3hB392m9QA%3D%3D; Domain=.m.taobao.com; Expires=Fri, 10-Jan-2014 06:04:34 GMT; Path=/
Set-Cookie: loginandbuyonly=bc8846b2c55e21; Domain=.m.taobao.com; Expires=Fri, 06-Dec-13 04:45:18 GMT; Path=/; HttpOnly
TBTrack-Id: du=d63e8994ab076e9c
Transfer-Encoding: chunked
Vary: Accept-Encoding
X-TB-BD: generic web browser


with Firefox OS (Alcatel One Touch Fire aka buri)

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.taobao.com
User-Agent:  Mozilla/5.0 (Mobile; ALCATEL ONE TOUCH 4012A; rv:18.1) Gecko/18.1 Firefox/18.1

HTTP/1.1 200 OK
Connection: keep-alive
Content-Encoding: gzip
Content-Language: zh-CN
Content-Type: text/html;charset=UTF-8
Date: Fri, 10 Jan 2014 02:06:01 GMT
Server: nginx
Set-Cookie: imewweoriw=2cD7KOtwoAjzUcA10vKcFA%3D%3D; Domain=.m.taobao.com; Expires=Fri, 10-Jan-2014 06:06:01 GMT; Path=/
Set-Cookie: loginandbuyonly=77b3928f0d98b1; Domain=.m.taobao.com; Expires=Fri, 06-Dec-13 04:45:18 GMT; Path=/; HttpOnly
TBTrack-Id: du=7cc02c67142dd7d5
Transfer-Encoding: chunked
Vary: Accept-Encoding
X-TB-BD: generic web browser


with Android Firefox

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.taobao.com
User-Agent:  Mozilla/5.0 (Android; Mobile; rv:18.1) Gecko/18.1 Firefox/18.1

HTTP/1.1 200 OK
Connection: keep-alive
Content-Encoding: gzip
Content-Language: zh-CN
Content-Type: text/html;charset=UTF-8
Date: Fri, 10 Jan 2014 02:06:47 GMT
Server: nginx
Set-Cookie: imewweoriw=iG%2Bgc9PFAKR9Ftg%2F8u1U8A%3D%3D; Domain=.m.taobao.com; Expires=Fri, 10-Jan-2014 06:06:47 GMT; Path=/
Set-Cookie: loginandbuyonly=486176402a0a5c; Domain=.m.taobao.com; Expires=Fri, 06-Dec-13 04:45:18 GMT; Path=/; HttpOnly
TBTrack-Id: du=f248d5557a1c88ca
Transfer-Encoding: chunked
Vary: Accept-Encoding
X-TB-BD: Generic
X-TB-M: Android
X-TB-OS: Android

http -b http://m.taobao.com/ "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" > taobao-android.txt
http -b http://m.taobao.com/ "User-Agent: Mozilla/5.0 (Mobile; ALCATEL ONE TOUCH 4012A; rv:18.1) Gecko/18.1 Firefox/18.1" >taobao-alcatel.txt 
http -b http://m.taobao.com/ "User-Agent: Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" >taobao-fos.txt 

then 

→ ls -alh taobao-*
48K 2014-01-10 11:08 taobao-alcatel.txt
48K 2014-01-10 11:07 taobao-android.txt
48K 2014-01-10 11:08 taobao-fos.txt

git diff --color-words  taobao-alcatel.txt taobao-fos.txt
All differences are created by unique session ids in URIs

git diff --color-words  taobao-alcatel.txt taobao-android.txt 
Differences in unique session ids in URIs
AND differences in the CSS which seem to be cosmetic such as

diff --git a/taobao-alcatel.txt b/taobao-android.txt
index 2cefadb..66ffdf7 100644
--- a/taobao-alcatel.txt
+++ b/taobao-android.txt
@@ -35,37 +35,35 @@ body{color:#333;}
 .center{text-align:center}
 hr{margin:10px 0;height:0px;border:none;border-top:1px #999 solid;color:#999}
 
-body,div,p,h1,h2,h3,em,span,a,td,form,input,select,textarea{margin:0;padding:0;font-size:14px;line-height:19px;font-style:normal;}
-.login,.crumbs,.box h2,.box h3,.box .detail,.pager,.ft,.tab,.sub-tab{padding:0 6px;}
-.txt{height:24px;border:1px #b7b7b7 solid;}
-.btn,.btn-blue{height:26px;padding:0 12px;color:#fff;}
+body,div,p,h1,h2,h3,em,span,a,td,form,input,select,textarea{margin:0;padding:0;font-size:13px;line-height:18px;font-style:normal;}
+.login,.crumbs,.box h2,.box h3,.box .detail,.pager,.ft,.tab,.sub-tab{padding:0 3px;}
+.txt{height:20px;border:1px #b7b7b7 solid;}
+.btn,.btn-blue{height:22px;padding:0 10px;color:#fff;}


Not sure that's really a bug or it is worth contacting them for this.
To be clearer on my Android device, I get the screenshot on the right side of the attachment aka the same than Firefox OS.
"Mozilla/5.0 (Android; Mobile; rv:23.0) Gecko/23.0 Firefox/23.0"

It's why I'm asking what was the User Agent tested on both devices. 
Alcaltel One Touch Fire and the Android device.

Oh. I just realized the bug was about "Android browser" and not "Firefox Android browser". Hmmm…
Let's take a generic Android browser

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.taobao.com
User-Agent:  Mozilla/5.0 (Linux; U; Android 2.3.3; zh-tw; HTC_Pyramid Build/GRI40) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1

HTTP/1.1 200 OK
Connection: keep-alive
Content-Encoding: gzip
Content-Language: zh-CN
Content-Type: text/html;charset=UTF-8
Date: Fri, 10 Jan 2014 02:40:29 GMT
Server: nginx
Set-Cookie: imewweoriw=2OM1lz5auBHTgz2gs%2F6sEg%3D%3D; Domain=.m.taobao.com; Expires=Fri, 10-Jan-2014 06:40:29 GMT; Path=/
Set-Cookie: loginandbuyonly=4a6785e245be71; Domain=.m.taobao.com; Expires=Fri, 06-Dec-13 04:45:18 GMT; Path=/; HttpOnly
TBTrack-Id: du=6255861524ee9d6a
Transfer-Encoding: chunked
Vary: Accept-Encoding
WapVersion: aXBob25l
X-TB-BD: HTC
X-TB-M: PH06130
X-TB-OS: Android


ls -alh taobao-*
48K 2014-01-10 11:08 taobao-alcatel.txt
48K 2014-01-10 11:07 taobao-android.txt
21K 2014-01-10 11:41 taobao-androidstock.txt
48K 2014-01-10 11:08 taobao-fos.txt


ok :) different content.
Status: NEW → ASSIGNED
See Also: → 921556
Summary: [B2G][Browser]m.taobao.com on FxOS displays different site than on Android. → m.taobao.com sends a different site for Firefox OS/Firefox Android than on Android stock browser.
Whiteboard: dogfood1.3 → dogfood1.3 [country-cn] [serversniff] [contactready]
duplicate of 784478, no?
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 784478
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.