[B2G][Gallery] Turning device to landscape mode while in gallery causes it to have broken UI

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: tnguyen, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8357909 [details]
screenshot

Description:
While in the Gallery App, the user can turn the device to landscape mode and experience other images being displayed resulting in a broken UI. When the user navigates through the images after experiencing the broken UI, the Gallery App will revert back to its normal state. 

Repro Steps:
1) Updated Buri to BuildID: 20140109040203
2) Navigate to Gallery App
3) Select any image in that is in the middle
4) Turn device to landscape mode

Actual:
Images on left and right side of the selected image appears when attempting to view original image in landscape mode

Expected:
Only the original image is present when device is in landscape mode

Environmental Variables:
Device: Buri Master M-C mozRIL
BuildID: 20140109040203
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 9409405e0739
Version: 29.0a1
Firmware Version: V1.2_US_20131115

Notes:

Repro frequency: 3/3 100%
See attached: screenshot
Does this reproduce on 1.2?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #1)
> Does this reproduce on 1.2?

And what about 1.3?
QA Contact: rkunkel
(In reply to Jason Smith [:jsmith] from comment #2)
> (In reply to Jason Smith [:jsmith] from comment #1)

> Does this reproduce on 1.2?

Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140108004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 0d8b879ffd70
Version: 26.0
Firmware Version: 20131115

> And what about 1.3?

This issue does not occur on the latest v1.3 Buri buid.

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140109004002
Gaia: 22bc6be5b76cdc6d4e9667ff070979041a20ce2f
Gecko: 2c8f8683bd0d
Version: 28.0a2
Firmware Version: 20131115
Keywords: qawanted
(In reply to Roland Kunkel [:RolandK] from comment #3)
> (In reply to Jason Smith [:jsmith] from comment #2)
> > (In reply to Jason Smith [:jsmith] from comment #1)
> 
> > Does this reproduce on 1.2?
> 
> Environmental Variables:
> Device: Buri 1.2 MOZ
> BuildID: 20140108004002
> Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
> Gecko: 0d8b879ffd70
> Version: 26.0
> Firmware Version: 20131115
> 

Does this mean that this issue can be reproduced at 1.2??
The event 'screenlayoutchange' should be fired after the window had rotated. And we depend on this event to update the css. This bug is caused by that we use portrait screen width to relocate the previous and next frame in landscape.

The reposition code is at[1]. It depends on the window.innerWidth to do so. When we get the event 'screenlayoutchange' before the value changed, we get this issue.

CC: George to let him know this because he is the author of screen_layout.js

[1] https://github.com/mozilla-b2g/gaia/blob/876b3f96fd4e5e92183ca12bb2c8b9e9bea69e79/apps/gallery/js/frames.js#L388
Need info - see comment 4
Flags: needinfo?(rkunkel)

Updated

5 years ago
blocking-b2g: --- → 1.4?
Keywords: regression, regressionwindow-wanted
(In reply to Jason Smith [:jsmith] from comment #6)
> Need info - see comment 4

This issue does not reproduce in the 1.2 build listed.
Flags: needinfo?(rkunkel)

Comment 8

5 years ago
This issue started reproducing on the 01/09/14 Master (1.4) build.

- Works -
Environmental Variables:
Device: Buri Master (1.4) MOZ RIL
BuildID: 20140108040200
Gaia: b7a7191f761933fd4878227488c75d09f5ba890c
Gecko: cf2d1bd796ea
Version: 29.0a1
RIL Version:
Firmware Version: V1.2_US_20131115

- Broken -
Environmental Variables:
Device: Buri Master (1.4) MOZ RIL
BuildID: 20140109040203
Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
Gecko: 9409405e0739
Version: 29.0a1
Firmware Version: V1.2_US_20131115
Keywords: regressionwindow-wanted

Comment 9

5 years ago
John - assigning this regression issue (on master) to you
Assignee: nobody → johu
(In reply to Matthew Vaughan from comment #8)
> This issue started reproducing on the 01/09/14 Master (1.4) build.
> 
> - Works -
> Environmental Variables:
> Device: Buri Master (1.4) MOZ RIL
> BuildID: 20140108040200
> Gaia: b7a7191f761933fd4878227488c75d09f5ba890c
> Gecko: cf2d1bd796ea
> Version: 29.0a1
> RIL Version:
> Firmware Version: V1.2_US_20131115
> 
> - Broken -
> Environmental Variables:
> Device: Buri Master (1.4) MOZ RIL
> BuildID: 20140109040203
> Gaia: 47206ac66b084c6f6c4503a3b10d0e0760df2b6f
> Gecko: 9409405e0739
> Version: 29.0a1
> Firmware Version: V1.2_US_20131115

Matthew,

Because I cannot find any clue within this regression window, I had tested 20140108040200 from PVT server with my Inari and found it is still reproducible.

I may need your help to confirm that. Thanks.
Flags: needinfo?(mvaughan)
This bug may not be reproduced when image is scanning. After all images are scanned, it is more easy to reproduce.
Sorry. I think I should not use Inari to test this. When I change to helix, I cannot reproduce this with 20140108040200 build. I think it may related to the gecko change so that I cannot find any clues in gaia repository.
Flags: needinfo?(mvaughan)
I found I can reproduce it from 20131221040201 which is also the version we found the white screen of inari build.
Created attachment 8359696 [details]
apz problem with helix

When APZ is enabled, the sequence of event dispatch of MediaQueryList is wrong. The listener of MediaQueryList should be called after the value changed. But it is called before value changed while APZ is enabled.

In this bug, we use (orientation: portrait) to watch the change of orientation. The listener should be called after user rotate the phone. But it is called before that when APZ is enabled.

If we disable APZ, it works correctly, like the behavior of the attached video.
Created attachment 8359699 [details]
apz problem with inari

The attached video shows the same thing when I using Inari to test it. That's also why I can reproduce it with the version at 2014/01/08.
The regression window may only reflect the change of default setting of APZ.

When we use older version, like 20131220040201 in inari, we have disabled APZ in default. This issue is reproducible when we enable APZ with the same version. So, this bug may be a regression bug before that.

Jason, may you help me to redirect this to the correct person? I don't know who is the correct person to handle this.
Flags: needinfo?(jsmith)
Unassign myself because this is caused by APZ.
Assignee: johu → nobody
Moving over to panning & zooming then if it's APZC related.
Component: Gaia::Gallery → Panning and Zooming
Flags: needinfo?(jsmith)
Product: Firefox OS → Core
A workaround of this bug can be to replace the screenlayoutchange event with resize event. The screenlayoutchange event is built upon the MediaQueryListListener.

But once using resize event, there may be another issue that multiple resize events are dispatched on simulator of Firefox Nightly because of the rotation animation.
(Reporter)

Updated

5 years ago
Duplicate of this bug: 961669
Can we retest if this is happening on the latest 1.4?
Keywords: qawanted

Comment 22

5 years ago
This issue does not reproduce for me on the 02/18/14 1.4 build.

Device: Buri v1.4 MOZ RIL
BuildID: 20140218040203
Gaia: ae90f9b322509ee09fbd3963bd23e142845613ab
Gecko: 318c0d6e24c5
Version: 30.0a1
Firmware Version: V1.2-device.cfg
Keywords: qawanted

Updated

5 years ago
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.