Popcorn remix will not play

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: julia, Assigned: thecount)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
1. I am having trouble with this popcorn video:
https://popcorn.webmaker.org/templates/basic/?savedDataUrl=tour.json

I have renamed it and saved it several times, but it will not play back in any of these published links

https://juliavallera.makes.org/popcorn/1ong
https://juliahivenyc.makes.org/popcorn/1onm
https://juliahivenyc.makes.org/popcorn/1ona

2. also this popcorn tutorial is not playing
https://mozteach.makes.org/popcorn/1boj

but the content seems to be there when you click the remix button
https://popcorn.webmaker.org/editor/61795/remix

I tried to rename it and re-save it...the new link will not play
https://juliahivenyc.makes.org/popcorn/1onn
Hey Julia,

We were having problems related to Vimeo and it looks like the cause of the problems there is the same thing your seeing here.

I tried this out locally which we have a fix for it and thankfully this seems to be fixed. I pushed that code up to our staging server just now. Can you check if https://popcorn.mofostaging.net/templates/basic/?savedDataUrl=tour.json has any issues for you? Try in a few minutes after reading this because it's literally in the process of building :)
the media in this project is HTML5, not Vimeo - I see:

TypeError: type is undefined embed.js:13773

in the console.
(In reply to Chris DeCairos (:cade) from comment #2)
> the media in this project is HTML5, not Vimeo - I see:

link was: https://juliavallera.makes.org/popcorn/1ong
I am aware of that Chris. The patch I am speaking off touches more than Vineo and it fixes this problem from my own testing. I'm on a bus right now and will check in later.
(Reporter)

Comment 5

5 years ago
I can see the stage and content here: https://popcorn.mofostaging.net/templates/basic/?savedDataUrl=tour.json but when I sign on to save with persona it is asking me to create a new makes.org account name. It doesn't seem to link to my juliahivenyc account that already exists, so I cannot save and try the new link.
That's to be expected Julia. Our staging servers are different environments so it doesn't mirror the data you have on our production servers. It's mostly a testing ground. You should be able to create an account with the same name and everything that will work but will point to something that is our staging equivalent of makes.org
(Reporter)

Comment 7

5 years ago
Ah, I see. Thank you. I saved it and republished, but the video still is not playing:
https://juliahivenyc.mywebmaker.org/popcorn/14jz
(Assignee)

Comment 8

5 years ago
Yeah, confirmed this is broken.

I think while similar, this is not the same as the Vimeo issue.

I think there is a chance here that broke us.

I could be missing it but we don't even have a check for html5, and why would we, there is no way to tell. We always just assumed it was html5 if it failed all the checks.
(Assignee)

Comment 9

5 years ago
bug 945373 broke this.

Shouldn't be hard.
Assignee: nobody → scott
(Assignee)

Comment 10

5 years ago
Created attachment 8358133 [details] [review]
https://github.com/mozilla/popcorn.webmaker.org/pull/408

This also broke sequence editors that were html5. The fallback input was no longer being displayed.

I think it's safe to return this still. I only removed it because it technically wasn't html5 and did one check that needs to worry about audio or images too, but that check is simply an } else { and can ignore the html5 part.
Attachment #8358133 - Flags: review?(schranz.m)
(Assignee)

Comment 11

5 years ago
Julia, thanks for bringing this to our attention. Huge help. I have a fix and should be landed shortly. I'll update this ticket and let you know when it is fixed and on popcorn.webmaker.org. It is reasonable to expect it done tomorrow around noon.
Attachment #8358133 - Flags: review?(schranz.m) → review+
(Assignee)

Comment 12

5 years ago
Staged: https://github.com/mozilla/popcorn.webmaker.org/commit/1d1b17398d2c4eb455c4591e475c81edaabec1eb

Needs verification.

Not on popcorn.webmaker.org yet.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(scott)
Resolution: --- → FIXED
(Assignee)

Comment 13

5 years ago
Should be working now on popcorn.webmaker.org
Status: RESOLVED → VERIFIED
Flags: needinfo?(scott)
You need to log in before you can comment on or make changes to this bug.