Closed Bug 958338 Opened 6 years ago Closed 6 years ago

[B2G][Settings][FDN] There is no indication to alert the user when enabling FDN and dialing to a contact that is not on FDN white list

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C3/1.4 S3(31jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed

People

(Reporter: selkabule, Assigned: etienne)

Details

(Keywords: regression, Whiteboard: dogfood1.3)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
ferjm
: review+
Details | Review
Description:
When the user enables FDN and makes and makes an attempt to make a call to a number or a contact that is not on the FDN white list

Repro Steps:
1. Enable FDN from settings app
2. Launch the Contact app and select a contact not on the FDN white list
3. Tap on the phone number

Expected Result:
 A page shows that the number I am dialing is not on the white list

Actual Result:
 No response

Environmental Variables
Device: buri 1.3 Moz Ril 
Build ID: 20140107004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71ad7ff30010
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Platform Version: 28.0a2

Repro frequency: 100%
See attached: video clip(http://www.youtube.com/watch?v=ZaHA5WHOjRM&edit=vd)


Notes:
This issue does not reproduce on buri 1.2 

1.2 Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140108004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 0d8b879ffd70
Version: 26.0
Firmware Version: 20131115
blocking-b2g: --- → 1.3?
QA Contact: sparsons
This issue started to occur on the Buri 1.3 Build ID: 20131206040203

Gaia   8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
SourceStamp 1401e4b394ad
BuildID 20131206040203
Version 28.0a1

Last working Buri 1.3 Build ID: 20131205040201 

Gaia   1dd0e5c644b4c677a4e8fa02e50d52136db489d9
SourceStamp 725c36b5de1a
BuildID 20131205040201
Version 28.0a1
1.3+ for regression.
blocking-b2g: 1.3? → 1.3+
The code didn't change since the initial FDN patch [1].

Is this happening only on buri?

[1] https://github.com/mozilla-b2g/gaia/commit/d562425f13fbefc8ef64a8d660196a22ee9ef79c
Keywords: qawanted
As of right now, the Buri is the only device we use to test 1.3. 

(In reply to Etienne Segonzac (:etienne) from comment #4)
> The code didn't change since the initial FDN patch [1].
> 
> Is this happening only on buri?
> 
> [1]
> https://github.com/mozilla-b2g/gaia/commit/
> d562425f13fbefc8ef64a8d660196a22ee9ef79c
Keywords: qawanted
Assignee: nobody → kaze
Talked with Kaze, he will test on a non-buri phone to see if this is vendcom or not.
Assignee: kaze → nobody
Flags: needinfo?(kaze)
I can’t reproduce on my Unagi with the 1.3 branch. Vendom issue?
Flags: needinfo?(kaze)
(In reply to Fabien Cazenave [:kaze] from comment #7)
> I can’t reproduce on my Unagi with the 1.3 branch. Vendom issue?

I guess so.
Component: Gaia::Dialer → Vendcom
My bad: I get the FDN message when trying to send an SMS but it doesn’t work when trying to do a phone call.

I can reproduce it with the master branch on my Unagi ⇒ Dialer bug. Taking.
Assignee: nobody → kaze
Component: Vendcom → Gaia::Dialer
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
Etienn, it appears it is a dialer bug.
Assignee: kaze → etienne
Attached file Gaia PR
Simple patch, just a un-handled error message.
(Keeping the support for FDNBlockedError too, since this is what we get on some devices)
Attachment #8368490 - Flags: review?(ferjmoreno)
Comment on attachment 8368490 [details] [review]
Gaia PR

LGTM
Attachment #8368490 - Flags: review?(ferjmoreno) → review+
https://github.com/mozilla-b2g/gaia/commit/96b7f29877e7c73c1568261278cd9668b8518e0d
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Uplifted 96b7f29877e7c73c1568261278cd9668b8518e0d to:
v1.3: fd4702dc302758f04390e8cd5542d0ddf7a45dbd
You need to log in before you can comment on or make changes to this bug.