Performance Regression for Tab dragging

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: Morpheus3k, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Since I've updated the nightly build to the newest release, dragging a tab on OS X lags.

STR:
1. drag a tab

Expected:
Smooth animation until build from 2014-01-08 or the first build from 2014-01-09 (good performance)
http://hg.mozilla.org/mozilla-central/rev/effa95701c83

Actual:
Animation is lagging with second build from 2014-01-09 (bad performance)
http://hg.mozilla.org/mozilla-central/rev/effa95701c83


Tested on OS X 10.9.1 on a mac mini 2011.

Comment 1

5 years ago
This worked yesterday, so I'm just going to go ahead and needinfo mstange again... ;-)

Presumably this is related to bug 958025?
Flags: needinfo?(mstange)
(Reporter)

Comment 2

5 years ago
Copy and paste error. Sorry, here are the right build sources:

Expected:
Smooth animation until build from 2014-01-08 or the first build from 2014-01-09 (good performance)
http://hg.mozilla.org/mozilla-central/rev/711f08b0aa1d

Actual:
Animation is lagging with second build from 2014-01-09 (bad performance)
http://hg.mozilla.org/mozilla-central/rev/effa95701c83
I can't reproduce this. The animation is still very smooth for me in the latest nightly. Which OS X are you on? I'm on 10.8.5. Also, can you paste the contents of the Graphics section on about:support?
Flags: needinfo?(mstange)
(Reporter)

Comment 4

5 years ago
I've originally tested this on a Mac mini from 2011 with Intel HD3000 on OS X 10.9.1. I can access this Mac not before Monday.

But I've just tested this on a MacBook Pro from 2012 with Intel HD4000 on OS X 10.9.1 and still can reproduce this behavior.

This is the Graphics section on about:support for the MacBook (2012):

Device ID                   0x 166
GPU Accelerated Windows     1/1 OpenGL (OMTC)
Vendor ID                   0x8086
WebGL Renderer              Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
windowLayerManagerRemote    true
AzureCanvasBackend          quartz
AzureContentBackend         quartz
AzureFallbackCanvasBackend  none
AzureSkiaAccelerated        0

Graphic information from OS X:

Chipset Model:    Intel HD Graphics 4000
Type:             GPU
Bus:              Built-In
VRAM (Total):     1024 MB
Vendor:           Intel (0x8086)
Device ID:        0x0166
Revision ID:      0x0009
(Reporter)

Comment 5

5 years ago
Here is the information about the Mac mini with HD3000 on OS X 10.9.1.


This is the Graphics section on about:support for the Mac mini (2011):

Device ID                   0x 126
GPU Accelerated             Windows 1/1 OpenGL (OMTC)
Vendor ID                   0x8086
WebGL Renderer              Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
windowLayerManagerRemote    true
AzureCanvasBackend          quartz
AzureContentBackend         quartz
AzureFallbackCanvasBackend  none
AzureSkiaAccelerated        0

Graphic information from OS X:

Chipset Model:    Intel HD Graphics 3000
Type:             GPU
Bus:              Built-In
VRAM (Total):     512 MB
Vendor:           Intel (0x8086)
Device ID:        0x0126
Revision ID:      0x0009
(Reporter)

Comment 6

4 years ago
I don't have any performance regressions in the latest nightly anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.