Closed Bug 958506 Opened 6 years ago Closed 5 years ago

ebay.com - Button is not correctly displayed on Ebay Shopping Cart webpage

Categories

(Web Compatibility :: Desktop, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: adalucinet, Unassigned)

References

()

Details

(Keywords: top100, Whiteboard: [contactready])

Attachments

(1 file)

Reproducible on:
Firefox 27 Beta 5 (Build ID: 20140109165205): 
Mozilla/5.0 (X11; Linux i686; rv:27.0) Gecko/20100101 Firefox/27.0
latest Aurora (Build Id: 20140110004002):
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0
latest Nightly (Build Id: 20140110030650):
Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0

Steps to reproduce:
1. Launch Firefox.
2. Navigate to http://www.ebay.com/.
3. Add to cart any product. 

Expected results: "Proceed to checkout" button is properly displayed.

Actual results: "Proceed to checkout" button is not properly displayed.


Notes:
1. Not reproducible on Mac OS X nor Windows.
2. Not a recent regression, this issue is reproducible with Firefox 26 (Build Id: 20131205075310).
3. Not reproducible with Chrome nor Opera.
Not a regression, this issue is reproducible with Firefox 4.0.1 too.
The width of the text is slightly wider in Firefox, probably due to a slightly
larger default font size, so "checkout" doesn't fit within the button width
and is laid out on the next line.  The button is styled with a fixed height
(height:34px) so the lower part of "checkout" spills outside and since the
text is white and the background outside the button is white you can't read it.

This is an error in the web page design, not in Firefox.
Assignee: nobody → esperanto
Component: Layout: View Rendering → Esperanto
Keywords: top100
Product: Core → Tech Evangelism
Summary: Button is not correctly displayed on Ebay Shopping Cart webpage → ebay.com - Button is not correctly displayed on Ebay Shopping Cart webpage
Assignee: esperanto → english-us
Component: Esperanto → English US
Issue still exists in FF 29 and Nightly 32 (Linux)
Assignee: english-us → nobody
Component: English US → Desktop
WFM in Nightly 36 (Linux)
Whiteboard: [contactready]
and on win. assuming fixed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.