Profile migration needs to record info about what it was migrated from

VERIFIED DUPLICATE of bug 87619

Status

VERIFIED DUPLICATE of bug 87619
18 years ago
3 years ago

People

(Reporter: ccarlen, Assigned: ccarlen)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

It's possible for the user to
1. Migrate a 4.x profile to a 6.x profile of the same name
2. Go back and use 4.x for a while, getting more mail
3. Try the next, better version of 6.x
4. The mail they collected in step 2 is not migrated and they're not happy

If we recorded, the profile from which a new profile was migrated, the mod date
of the newest item in the dir at that time, and a time stamp of when of profile
was last used by 6.x, we could remigrate (or ask the user if they want to)
remigrate the profile.

Another scenario in which this is helpful:
1. user starts up 6.x and chooses not to migrate, instead makes a new profile
called "fred"
2. now, at some later point, they want to migrate their old profile (also called
"fred")
3. they can't because, since we don't have this info and we don't want to
migrate profiles again and again, we don't migrate profiles which have the same
name as a new one.
(Assignee)

Updated

18 years ago
Blocks: 52344
(Assignee)

Comment 1

17 years ago
Marking as dup.

*** This bug has been marked as a duplicate of 87619 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified as a duplicate of 87619
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.