Resizing last column resizes other columns

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
9 years ago

People

(Reporter: risto.kankkunen, Assigned: hyatt)

Tracking

Trunk
mozilla1.0.1
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: nab-visual)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
1. Show columns Subject, Sender and Size.
2. Make the Size column narrower.

You'll notice that also the Sender and Subject columns have resized. Only two
columns should change sizes: one to narrow and one to widen.

This effect doesn't happen with every resize, but frequently.
(Reporter)

Comment 1

17 years ago
Created attachment 46305 [details]
Before resizing Size column
(Reporter)

Comment 2

17 years ago
Created attachment 46307 [details]
After narrowing Size column, both Subject and Sender have grown
(Reporter)

Comment 3

17 years ago
I can see even stranger things happen, but this is harder to reproduce:

Start from a similar situation, but now try to grow the last column, Size. Size
grows, but only marginally so that the divider leaves behind to the right of the
arrow cursor. What happens is that the Sender shrinks and the Subject grows
while you drag the cursor left. Once Sender is just wide enough to display the
title, it starts growing again while Subject shrinks, if you still move left.
Then no column resizes even if you move your mouse even further left.

Unfortunately I don't have means to capture the display with the cursor to
illustrate this scenario.

Comment 4

17 years ago
Risto, most of the bugs you are filing are not mailnews specific.

Reassign to XPToolkit.
Assignee: sspitzer → hyatt
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → XP Toolkit/Widgets: Trees
Ever confirmed: true
Product: MailNews → Browser
QA Contact: esther → jrgm
(Reporter)

Comment 5

17 years ago
Sorry! I thought if I have only found the problem in MailNews/W2000, I should
report that even if I suspect it might be a general XUL problem for all platforms...

Comment 6

17 years ago
Seems to get a little confused in how to distribute the widths over the columns
when one or more of the columns is hidden. [By the way, when is evaughan back?]
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
*** Bug 111534 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 111859 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 115606 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Whiteboard: nab-visual
*** Bug 117309 has been marked as a duplicate of this bug. ***
*** Bug 117180 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: Resising last column resizes other columns → Resizing last column resizes other columns
*** Bug 117699 has been marked as a duplicate of this bug. ***

Comment 13

17 years ago
*** Bug 124737 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
Changing OS to All based on duplicate reports.
OS: Windows 2000 → All

Comment 15

17 years ago
I can no longer reproduce this bug on 2002040314/Linux.
I think you can mark as FIXED or WORKSFORME.

Comment 16

17 years ago
Worksforme for both FTP listing and mailnews in 2002040311 OS/2.

Comment 17

17 years ago
As reporter of bug 124737 (marked dupe of this one) - I no longer see the
problem I was reporting

WFM 2002041203 (Win2k)

Comment 18

17 years ago
marking wfm per comments above, and testing in bookmarks and mailnews 
threadpane (4/13 win2k trunk build). Thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 19

17 years ago
*** Bug 129865 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.