N610 Trunk Browser crashes while printing [@ nsLineLayout::ReflowFrame]

VERIFIED DUPLICATE of bug 95420

Status

()

--
critical
VERIFIED DUPLICATE of bug 95420
17 years ago
17 years ago

People

(Reporter: carl.kumaradas, Assigned: dcone)

Tracking

({crash, topcrash})

Trunk
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802
BuildID:    2001080615

Print the URL page above and Mozilla crashes with a segmnetation fault 
after the "print" button on the print dialog is pressed.

Reproducible: Always
Steps to Reproduce:
1.Go to URL
2.Press print icon
3.Press "print" button in dialog

Actual Results:  All browser windows immediately close and "Segmentation fault"
is printed to the terminal.
(Assignee)

Comment 1

17 years ago
There is probably something else going on here.. you might look to see if the 
printer is configured ok.. we did have a bug with linux 6.1 crashing if the 
printer command was not configured correctly.  Can you supply some more 
information on this.
(Reporter)

Comment 2

17 years ago
Printing (using lpr, kprinter, etc) works fine for all apps I have tried,
including Mozilla for all web pages I've tried, except for this page.

I'm running Madrake 8.0 with cups-1.1.8 print server.

Comment 3

17 years ago
changing platform/OS to ALL. I can reproduce this crash.

talkback ID = 34270144
OS: Linux → All
Hardware: PC → All
(Assignee)

Comment 4

17 years ago
I can not reproduce this crash.  It works just fine.

Comment 5

17 years ago
Need the talkback info pasted here..
Severity: normal → critical
Keywords: crash

Comment 6

17 years ago
 Stack Trace

nsLineLayout::ReflowFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1031] 
nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3460] 
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3344] 
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3269] 
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3214] 
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2359] 
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2049] 
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 799] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsTableCellFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableCellFrame.cpp, line
756] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsTableRowFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line
882] 
nsTableRowFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowFrame.cpp, line
1241] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsTableRowGroupFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 378] 
nsTableRowGroupFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableRowGroupFrame.cpp,
line 1046] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsTableFrame::ReflowChildren
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 3050] 
nsTableFrame::ReflowTable
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 2014] 
nsTableFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableFrame.cpp, line 1907] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsTableOuterFrame::OuterReflowChild
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
974] 
nsTableOuterFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\table\src\nsTableOuterFrame.cpp, line
1534] 
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
578] 
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
345] 
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2958] 
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2245] 
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2049] 
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 799] 
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
578] 
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
345] 
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2958] 
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2245] 
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2049] 
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 799] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsPageFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPageFrame.cpp, line 186] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
nsSimplePageSequenceFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsSimplePageSequence.cpp, line
346] 
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line
749] 
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 538] 
PresShell::ResizeReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2808] 
DocumentViewerImpl::ReflowPrintObject
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 2916] 
DocumentViewerImpl::ReflowDocList
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 2694] 
DocumentViewerImpl::SetupToPrintContent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 3212] 
PR_AtomicIncrement [../../../../pr/src/misc/pratom.c, line 302] 
nsDocShell::AddRef [d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp,
line 239] 
nsWebShell::AddRef [d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp,
line 231] 
nsWebShell::QueryInterface
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 258] 
nsQueryInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 37] 
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 66] 
DocumentViewerImpl::Print
[d:\builds\seamonkey\mozilla\content\base\src\nsDocumentViewer.cpp, line 4521] 
GlobalWindowImpl::Print
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 1864] 
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 139] 
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line
1886] 
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1253] 
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 809] 
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2698] 
js_Execute [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 988] 
JS_EvaluateUCScriptForPrincipals [d:\builds\seamonkey\mozilla\js\src\jsapi.c,
line 3304] 
nsJSContext::EvaluateString
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 619] 
nsJSThunk::EvaluateScript
[d:\builds\seamonkey\mozilla\dom\src\jsurl\nsJSProtocolHandler.cpp, line 226] 
nsJSChannel::AsyncOpen
[d:\builds\seamonkey\mozilla\dom\src\jsurl\nsJSProtocolHandler.cpp, line 540] 
nsDocumentOpenInfo::Open
[d:\builds\seamonkey\mozilla\uriloader\base\nsURILoader.cpp, line 185] 

Comment 7

17 years ago
Confirming this one. This stack trace shows up 189 times in the Talkback Windows 
N610 data and 10 times in today's Talkback Trunk data. With a single exception, 
the crash happens exclusively on Windows. 

N610 crash by platform:
   1 Linux 2.4.8-5mdk
   4 Windows 95  4.0 build 67109814
   6 Windows 95  4.0 build 67109975
   7 Windows 95  4.0 build 67306684
  38 Windows 98  4.10 build 67766222
  66 Windows 98  4.10 build 67766446
  49 Windows 98  4.90 build 73010104
   5 Windows NT  4.0 build 1381
  12 Windows NT  5.0 build 2195
   1 Windows NT  5.1 build 2505

Trunk Crash by platform:             Mozilla Build:
   1 Windows 95  4.0 build 67109975  2001081716
   1 Windows 98  4.10 build 67766446 2001081716
   1 Windows 98  4.10 build 67766446 2001082406
   1 Windows NT  5.0 build 2195      2001082309
   1 Windows NT  5.0 build 2195      2001082406
   5 Windows NT  5.0 build 2195      2001082511

I'll include the stack (for comparison) and user comments below.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: topcrash
Summary: Browser chrashes while printing → N610 Browser crashes while printing [@ nsLineLayout::ReflowFrame]

Comment 8

17 years ago
Created attachment 47437 [details]
Stack trace

Comment 9

17 years ago
Created attachment 47438 [details]
Talkback User Comments

Updated

17 years ago
Summary: N610 Browser crashes while printing [@ nsLineLayout::ReflowFrame] → N610 Trunk Browser crashes while printing [@ nsLineLayout::ReflowFrame]

Comment 10

17 years ago
This is a dupe...bug 95420

*** This bug has been marked as a duplicate of 95420 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 11

17 years ago
v
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsLineLayout::ReflowFrame]
You need to log in before you can comment on or make changes to this bug.