Closed Bug 958809 Opened 6 years ago Closed 6 years ago

Privacy level may be ignored for broadcasted data

Categories

(Firefox :: Session Restore, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox26 --- unaffected
firefox27 --- unaffected
firefox28 + fixed
firefox29 --- fixed

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

(Whiteboard: [qa-])

Attachments

(1 file)

When working on bug 951675 I forgot to remote the .updateField() and .removeField() calls that put broadcasted data into the TabStateCache. This fixes some intermittent failures that occur with the patch from bug 947212 where data remains in the tabState object although the PrivacyLevelFilter would have removed it.
Blocks: 947212
Attachment #8358779 - Flags: review?(dteller) → review+
https://hg.mozilla.org/mozilla-central/rev/ee80588ead20
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Comment on attachment 8358779 [details] [diff] [review]
0001-Bug-958809-Don-t-put-broadcasted-data-into-the-regul.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 930967
User impact if declined: privacy level chosen by the user may be ignored and we end up saving data data shouldn't be retained
Testing completed (on m-c, etc.): landed on m-c without issues
Risk to taking this patch (and alternatives if risky): low risk, small patch
String or IDL/UUID changes made by this patch: None.
Attachment #8358779 - Flags: approval-mozilla-aurora?
Attachment #8358779 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Tim, is there something QA can do to verify this is fixed? Does this or should this have in-testsuite coverage?
Flags: needinfo?(ttaubert)
Flags: in-testsuite?
No, there is nothing that QA can do to verify this. This was failing intermittently and I alas didn't manage to write a reliable test for this.
Flags: needinfo?(ttaubert)
Whiteboard: [qa-]
Flags: in-testsuite? → in-testsuite-
You need to log in before you can comment on or make changes to this bug.