Closed Bug 958813 Opened 7 years ago Closed 7 years ago

Hovering over Australis History Panel should show the url on the status bar

Categories

(Firefox :: Tabbed Browser, defect)

29 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tabutils+bugzilla, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140110030650

Steps to reproduce:

STR:
1/ Open some tabs and close them one by one
2/ Click "Customize and Control Nightly" button and select History
3/ Move cursor up and down on history items


Actual results:

No url is shown on bottom of window


Expected results:

The history url should be shown on bottom of window
Component: Untriaged → Tabbed Browser
Have you tried Nightly safe-mode ?  The URL on hovered History items is shown on the item in the History list, there is no reason that I see for it to be in the lower left corner as that would just require too much back-and-forth eye movement between History items and the associated URL with that item.

I'm assuming you don't see the URL at all ?
I do see the tooltips with URL. But I also see inconsistent behaviors between History Menu and History Panel. Hovering on History menu items or Bookmarks items will show url in the lower left corner.
Confirmed in 29.0a1 (2014-01-30), win 7 x64
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Hovering over Australis History Panel should show the url on bottom → Hovering over Australis History Panel should show the url on the status bar
This varies by platform and place...

From the menubar, we show these previews on Windows but not OS X.

From the menupanel subviews, we don't show these previews.

From the bookmarks-on-navbar panel, we show the preview for bookmarks but not for history.

From a quick chat with shorlander, we're going to wontfix this. The tooltip already exposes this info, and is generally where the eye is looking (ie, near the pointer). Arguably we should remove the link preview from the other places, but I don't think we're in any hurry to do that.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
That's fine. Just make it clear that it's a decision, not a bug.
You need to log in before you can comment on or make changes to this bug.