Closed Bug 958877 Opened 11 years ago Closed 11 years ago

Use HTTPS for Wikipedia searches

Categories

(Firefox :: Search, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 758857

People

(Reporter: briansmith, Assigned: briansmith)

References

Details

(Keywords: privacy)

Attachments

(1 obsolete file)

+++ This bug was initially created as a clone of Bug #958873 +++

Wikipedia search now works in a useful way. Let's switch Wikipedia in the search box to use HTTPS like we did for Google in bug 633773 and Bing in bug 958873.

Note that Wikipedia does something special regarding HTTPS for China and Iran. So, there may be special localization concerns here.

I manually tested this in desktop Firefox, including search suggestions, and everything seems to be working fine
Attached patch wikipedia-https.patch (obsolete) — Splinter Review
Attachment #8358856 - Flags: review?(gavin.sharp)
Ryan Lane seems to be a good person at Wikimedia to talk to about this, since he wrote http://blog.wikimedia.org/2013/08/01/future-https-wikimedia-projects/.

Ryan, do you have any concerns about this change? It makes Wikipedia searches from Firefox's search box use HTTPS instead of HTTP. It doesn't force Wikipedia to be HTTPS-only; for example, a user that does a Google search that includes an HTTP link will still connect to Wikipedia over HTTP and not HTTPS like normal. This change is for English localizations of Firefox that use en.wikipedia.org, but I expect that our localizers would make analogous changes for other subdomains in other localizations, unless we give specific instructions. Are there any specific subdomains/locales that we should avoid making this change for?
Flags: needinfo?(rlane)
Keywords: privacy
Dupe of bug 758857 which is linked to https://bugzilla.wikimedia.org/show_bug.cgi?id=45765 ? Five months ago Ryan said they weren't ready for the change (bug 758857 comment 13). Maybe that bug should be re-opened?
Thanks Matt. I re-opened that bug.

Ryan: It would be great to get notified when you are ready for this change. I didn't know about the other bug where people had already repeatedly asked you about it, and I'm sorry for pestering you about it.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Attachment #8358856 - Attachment is obsolete: true
Attachment #8358856 - Flags: review?(gavin.sharp)
clearing NEEDINFO.
Flags: needinfo?(rlane)
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: