Closed Bug 958885 Opened 6 years ago Closed 3 years ago

Use HTTPS for eBay searches from the search box

Categories

(Firefox :: Search, enhancement)

enhancement
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
platform-rel --- ?

People

(Reporter: briansmith, Assigned: kev)

References

Details

(Keywords: privacy, Whiteboard: [platform-rel-eBay])

+++ This bug was initially created as a clone of Bug #958873 +++

eBay is one of only two remaining pre-installed search engines in the en-US localization that does not support HTTPS for searches. I have experimented with submitting searches to eBay such that they get redirected to HTTP. That seems to work, and it would send a nice message to eBay that we want searches to be done over HTTPS. As you can see from bug 771788, we're making great progress on making all the in-built functionality in Firefox use HTTPS by default, and this is likely to be a long pole.

Assigning to Kev for now since the first step seems to be a discussion with eBay about adding HTTPS support that doesn't just redirect to HTTP.
Kev, I think you are the person that would deal with eBay, based on bug 625115 comment 5.

When you talk to them, can you also ask them about finding another solution for the "agreement tracking" you mentioned in that comment, that doesn't use redirects? The problem with redirects is that they are really horrible for performance, especially on mobile.

I am sure we'll have no problem with finding people to write a patch once we hear back from eBay about which URLs to use.
Flags: needinfo?(kev)
I know this is being looked at elsewhere, and apologies for not responding here considerably earlier. mconnor and jnagel are probably best points of contact for this. eBay uses a redirection service, where queries hit a service that sets a session cookie and then redirects the user to eBay. I do not know if this service supports https at this point; it hasn't in the past (note its not the same thing as the generic search on ebay.*, it's an affiliate service which manages affiliate traffic/queries to eBay)
Flags: needinfo?(kev)
platform-rel: --- → ?
Whiteboard: [platform-rel-eBay]
Now that we've removed eBay (en-US in 49, remaining locales in 50), I'm going to mark this as INVALID.  (Slightly more accurate than WONTFIX, less likely to confuse folks.)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Duplicate of this bug: 1283672
You need to log in before you can comment on or make changes to this bug.