[OTA][Helix] "Order by last name" setting is inconsistent after update from v1.2 to v1.3.

RESOLVED DUPLICATE of bug 949688

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 949688
4 years ago
4 years ago

People

(Reporter: hlu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
"Order by last name" setting is inconsistent after update from v1.2 to v1.3.

* Build Info (Both Gecko and Gaia)
     Device    Helix
     Gaia      539a25e1887b902b8b25038c547048e691bd97f6
     Gecko     http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/e672faf1e6a1
     BuildID   20140111004004
     Version   26.0
     ro.build.version.incremental=eng.wanglei.20131212.005845
     ro.build.date=Thu Dec 12 00:58:58 CST 2013


* Reproduce Steps
  1. Flash Helix device to v1.2 build from PVT
  2. Change update URL to v1.3 (http://update.boot2gecko.org/helix/1.3.0/nightly/update_20140111004005.xml)
  3. Launch contacts and go to settings
  4. Enable "Order by last name"
  6. Perform check now to get the update notifcation
  7. Download the update package
  8. Install the upgrade package while the package is downloaded.
  
* Actual results:
    "Order by last name" is turned off after update from v1.2 to v1.3.

* Expected results:
    Any configuration should be kept after update.

Updated

4 years ago
Blocks: 958986
blocking-b2g: --- → 1.3+
Keywords: dataloss, regression

Comment 1

4 years ago
I have my doubts this is a  regression as the order by last name setting has never persisted until bug 949688 landed
(In reply to Jose M. Cantera from comment #1)
> I have my doubts this is a  regression as the order by last name setting has
> never persisted until bug 949688 landed

Ah okay. Then this isn't data loss from a user's perspective - duping then.
No longer blocks: 958986
Status: NEW → RESOLVED
blocking-b2g: 1.3+ → ---
Last Resolved: 4 years ago
Keywords: dataloss, regression
Resolution: --- → DUPLICATE
Duplicate of bug: 949688
You need to log in before you can comment on or make changes to this bug.