Intermittent browser_webconsole_bug_653531_highlighter_console_helper.js | inspector is highlighting

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philor, Assigned: pbro)

Tracking

({intermittent-failure})

Trunk
Firefox 29
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 unaffected, firefox29 fixed, firefox-esr24 unaffected)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=32885282&tree=Mozilla-Inbound
Windows 7 32-bit mozilla-inbound opt test mochitest-browser-chrome on 2014-01-12 00:40:40 PST for push d5d5fb7cb469
slave: t-w732-ix-010

01:05:10     INFO -  TEST-START | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js
01:05:10     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | we have the header node
01:05:10     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | Console message: [JavaScript Warning: "XUL box for hbox element contained an inline span child, forcing all its children to be wrapped in a block." {file: "resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/highlighter.js" line: 335}]
01:05:10  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | inspector is highlighting
01:05:10     INFO -  Stack trace:
01:05:10     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js :: performTestComparisons :: line 72
01:05:10     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: testScope/test_executeSoon/<.run :: line 734
01:05:10     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
01:05:10     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | Console message: [JavaScript Warning: "Error in parsing value for 'top'.  Declaration dropped." {file: "chrome://browser/content/devtools/spectrum-frame.xhtml" line: 0 column: 0 source: "NaNpx"}]
01:05:10     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | Console message: [JavaScript Warning: "Error in parsing value for 'left'.  Declaration dropped." {file: "chrome://browser/content/devtools/spectrum-frame.xhtml" line: 0 column: 0 source: "NaNpx"}]
01:05:10     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | Console message: [JavaScript Warning: "Error in parsing value for 'top'.  Declaration dropped." {file: "chrome://browser/content/devtools/spectrum-frame.xhtml" line: 0 column: 0 source: "NaNpx"}]
01:05:10     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | Console message: [JavaScript Warning: "Error in parsing value for 'left'.  Declaration dropped." {file: "chrome://browser/content/devtools/spectrum-frame.xhtml" line: 0 column: 0 source: "NaNpx"}]
01:05:11     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js | correct output for $0
(Reporter)

Comment 1

4 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=32881394&tree=Mozilla-Inbound
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

4 years ago
Assignee: nobody → pbrosset
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 8

4 years ago
I've started to investigate this. It's not failing locally of course, so I've added many logs and pushed to try again several times, but so far haven't reproduced the failure.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Patrick, is it possible this test regressed with the landing of bug 916443 ? Landing date seems close enough...
Status: NEW → ASSIGNED
Comment hidden (Treeherder Robot)
(Assignee)

Comment 27

4 years ago
Yes Mihai, I changed this test during the course of bug 916443, to adapt it to the new highlighter.
So it is related.
(Assignee)

Comment 28

4 years ago
I have a feeling this bug is due to the CSS animation normally applied to our highlighter.
It's normally disabled during tests, but it was not the case in this one.
I'll push to try and see.
Thanks!
Blocks: 916443
(Assignee)

Comment 30

4 years ago
Created attachment 8362518 [details] [diff] [review]
bug958966-intermittent-webconsole-highlighter.patch

Mihai, this test is failing because the highlighter is not shown predictably due to the CSS animation.
This test isn't about the highlighter at all (there are other tests for that) but instead about selecting a node for setting the value of $0.
So I removed the part dealing with checking the highlighter.
Ongoing try build seems to be pretty green so far: https://tbpl.mozilla.org/?tree=Try&rev=1a864078a310
Attachment #8362518 - Flags: review?(mihai.sucan)
Comment on attachment 8362518 [details] [diff] [review]
bug958966-intermittent-webconsole-highlighter.patch

Review of attachment 8362518 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Let's hope this fixes the intermittent failure. Thanks!

::: browser/devtools/webconsole/test/browser_webconsole_bug_653531_highlighter_console_helper.js
@@ +55,5 @@
> +    executeSoon(() => {
> +      EventUtils.synthesizeMouseAtCenter(h1, {}, content);
> +      inspector.toolbox.once("picker-stopped", () => {
> +        info("Picker mode stopped, H1 selected, now switching to the console");
> +        openConsole(gBrowser.selectedTab, performWebConsoleTests);

nit: openConsole(gBrowser.selectedTab).then(performWebConsoleTests)

(trying to phase-out the callback)
Attachment #8362518 - Flags: review?(mihai.sucan) → review+
(Assignee)

Comment 32

4 years ago
Created attachment 8362658 [details] [diff] [review]
bug958966-intermittent-webconsole-highlighter v2.patch

Thanks Mihai for the review.
Yeah, let's hope this will fix it, but judging by the number of green bcs in the green try, I'm pretty sure it will.
Attaching a v2 of this patch with the only change being the .then() you mentioned.
Attachment #8362518 - Attachment is obsolete: true
Attachment #8362658 - Flags: review+
(Assignee)

Comment 33

4 years ago
Fixed in fx-team: https://hg.mozilla.org/integration/fx-team/rev/e81c56e83687
Whiteboard: [fixed-in-fx-team]
(Reporter)

Comment 34

4 years ago
https://hg.mozilla.org/mozilla-central/rev/e81c56e83687
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
status-firefox27: --- → unaffected
status-firefox28: --- → unaffected
status-firefox29: --- → fixed
status-firefox-esr24: --- → unaffected
You need to log in before you can comment on or make changes to this bug.