Closed Bug 9590 Opened 21 years ago Closed 12 years ago

[feature] XPInstall not registering Uninstall info

Categories

(Core Graveyard :: Installer: XPInstall Engine, defect, P3)

All
Other
defect

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: dveditz, Assigned: dveditz)

References

Details

(Keywords: helpwanted)

Status: NEW → ASSIGNED
Target Milestone: M10
Blocks: 11020
Summary: XPInstall not registering Uninstall info → [feature] XPInstall not registering Uninstall info
Blocks: 7874
Blocks: 7884
Assignee: cathleen → dveditz
reassign to dveditz per today's bug meeting.
Blocks: 12805
Target Milestone: M10 → M14
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Target Milestone: M14 → M17
uninstall is not part of beta 1 requirement
Status: NEW → ASSIGNED
is this bug still valid?

I don't think we're going to use registry for uninstall info, do we?
It won't go into the thing called a registry, but we still have to store this 
information somewhere.
move to m30, put on helpwanted list
uninstall in xpinstall/smartudate is out.
Assignee: dveditz → cathleen
Status: ASSIGNED → NEW
Keywords: helpwanted
Target Milestone: M17 → M30
Parcelling out Cathleen's bugs
Assignee: cathleen → dveditz
Changing fictional "M30" to reality
Target Milestone: M30 → Future
Blocks: 96409
Status: NEW → ASSIGNED
circular dependency: this bug blocks bug 7884, and is also blocked by bug 7884
This apparently does not block bug 7874, bug 11020, bug 12805, and bug 96409,
since those have all been resolved.
No longer blocks: 7874, 11020, 12805, 96409
The scope of this bug is not clearly articulated; but it seems like it ought to
be blocked by bug 161508.
No longer blocks: 7884
Depends on: uninstaller
*** Bug 242077 has been marked as a duplicate of this bug. ***
The xpinstall script engine has been removed from the trunk, bugs in it are obsolete.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.