Email chat in Message app

RESOLVED DUPLICATE of bug 840515

Status

Firefox OS
Gaia::SMS
RESOLVED DUPLICATE of bug 840515
4 years ago
2 years ago

People

(Reporter: u430111, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131212173133

Steps to reproduce:

When i open a conversation with a contact in the Message app would be cool to message with him using the email as message medium. The way of writing could be the same as MMS, with a "send by email" option when longpressing the send button, or a way to default email for contact/whole message app (just some first draft/thoughts, it should be natural as sending a sms/mms for the user point of view).

Technically speaking, the email is sent to the recipient address with a, e.g., "[EMAIL_CHAT]" field in the subject field, then the message app parses the received email and show the message if the subject contain that identifier and if the address is in the contact list (or not, let the user choose, possibly spam-prone since email address is public and, unlike im's, this is a decentralized message system).

If the user set a subject, it could be added to the previous subject like "[EMAIL_CHAT]usersubject", the app shouldn't display the identifier part ([EMAIL_CHAT]).
Flagging our UX designer Ayman Maat for consideration.

Pobosky, I think we'll need to know why you need this. Is the existing E-mail app not useful for you? Is it too difficult to trigger the E-mail app from the Contacts app? Would switching to the E-mail app from the Messages app be good enough for you?

Please tell us your full use case and maybe we can work out a good solution.
Flags: needinfo?(aymanmaat)
Flags: needinfo?(pobosky)
(Reporter)

Comment 2

4 years ago
Thanks for the interest Julien :)

Just to clarify: the email client should remain, this draft is only to use the email as a way to deliver messages in the message app, like a im app. I don't know if email app has threaded conversation per contact, something like Whatsapp or similar apps.

The idea behind this draft is to give the user the way to chat/message with another contact just opening the message app without using sms/mms but just the email given in the marketplace registration (like on Android, you get Google Talk/Hangout account when registering on the phone first start) or a user defined address. 
It's similar in idea with iMessage from Apple, that use a proprietary Xmpp service to send message instead of sms/mms if the recipient is registered to iMessage and online. 
From the user pov it would be the same as sending a sms (or mms if an attachment is added, or the user chose to insert a custom subject): just write something/attach a file and send to the contact you want (the recipient address must be in the contact entry in address book obv, a sms/mms would be sent instead).

The identifier subject is used to divide these conversation email from the other email in the email app, the message app should display only the ones with that identifier.

I'm here for further doubts and questions, however this is only a first idea, i valuated only some pro not thinking too much about implementation of the idea and cons, like offline messaging (that's an important question, how can we be sure the recipient hasn't ended the internet plan and he can't receive the message? I have an idea to use Xmpp/jabber but better talk about this idea before filling another bug with something similar).
Flags: needinfo?(pobosky)
We support sending a MMS by email now. So we don't send an email using SMTP like the email app does, but still I think this bug can be duped to bug 840515.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 840515
Flags: needinfo?(aymanmaat)
You need to log in before you can comment on or make changes to this bug.