[NFC] NFC doesn't work anymore when draw near and back two devices with one opened and one locked.

VERIFIED FIXED in 1.3 C3/1.4 S3(31jan)

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: johnhu, Assigned: dgarnerlee)

Tracking

unspecified
1.3 C3/1.4 S3(31jan)
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reproduce prerequisite: two firefox os devices with NFC enabled

Summary:
   The behavior of NFC is not correct. After the test, the NFC of one device is no longer working and need to re-enable NFC through settings app.

STR:
1. enable NFC on both devices
2. lock one device with power button. The screen should be all black, not in the lock screen mode.
3. touch these two devices <=== Error: the opened device vibrates forever but the locked device not.
4. draw back two devices
5. touch two devices again <=== Error or Correct: The opened device vibrates once but the locked device not. This is the correct behavior when we have two opened devices, but not sure with this case.
6. draw back two devices
7. touch two devices again <=== Error: no more vibration.

After those 7 STR, the NFC is no long working at the locked device even if we unlock it. The opened device only vibrates when NFC tag leaving but not vibrates when tag touched.
Depend on Bug 959109, we need to disable nfc when screen is off.
Depends on: 959109
(In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #1)
> Depend on Bug 959109, we need to disable nfc when screen is off.

If we disable NFC when screen is off, I believe this bug will be gone.
(Assignee)

Updated

5 years ago
Depends on: 960222
(Assignee)

Comment 3

5 years ago
Created attachment 8364289 [details] [review]
Check screen and lock state at the same time. r=alive

Moved from Bug 959109.
(Assignee)

Comment 4

5 years ago
Comment on attachment 8364289 [details] [review]
Check screen and lock state at the same time. r=alive

This is the same patch, moved from 959109 to 959104, since it directly fixes the problems in this particular bug, with additional edge case fixes coming from 959109.
Attachment #8364289 - Flags: review?(alive)
Attachment #8364289 - Flags: review?(alive) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → dgarnerlee
(Assignee)

Comment 5

5 years ago
Travis tests passed.
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Attachment #8364289 - Attachment description: Check screen and lock state at the same time. → Check screen and lock state at the same time. r=alive
Master: cc10bd50f93bbf7fdf40195c70ffa38eb075e6ec
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.