If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

SeaMonkey
Build Config
RESOLVED FIXED
16 years ago
13 years ago

People

(Reporter: Andy Behrens, Assigned: blizzard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803
BuildID:    20010803

When mozilla start up, it prints the message "/usr/bin/mozilla: readlink:
command not found".  

Reproducible: Always
Steps to Reproduce:
1.Run 'mozilla' from a shell prompt.


Actual Results:  Mozilla printed 'readlink: command not found', then continued.

(1) I'm running Red Hat 7.0.
(2) /usr/lib/mozilla/plugins/libjavaplugin_oji.so IS a symbolic link.
(3) I do *not* have the 'tetex' rpm installed on my system.

On RH 7.0, the 'readlink' command isn't part of the core release -- it's
provided by the 'tetex' rpm.  The /usr/bin/mozilla script should define its own
version of readlink.  A one-line shell function could do it, either running
ls+awk or perl.

Comment 1

16 years ago
um. are you saying perl doesn't define readlink? because afaik the only caller 
is using perl.

This is the readlink query i used while searching mozilla's cvs, if you think 
one of the others is failing, please correct me...
http://lxr.mozilla.org/seamonkey/search?string=readlink
Assignee: asa → blizzard
Component: Browser-General → Build Config
QA Contact: doronr → granrose
Summary: at startup, complains that readlink is not found → RPM readlink fails?
(Assignee)

Comment 2

16 years ago
What RPM version is that?
(Reporter)

Comment 3

16 years ago
The program that's calling readlink is the shell script /usr/bin/mozilla.  On my
system, it's installed by the mozilla-0.9.3-0 rpm.

The section of the script where readlink is called is

    if [ ! -L /usr/lib/mozilla/plugins/libjavaplugin_oji.so ]; then
        return;
    fi
    
    VM_LINK=`readlink /usr/lib/mozilla/plugins/libjavaplugin_oji.so`
(Assignee)

Comment 4

16 years ago
I posted a 0.9.3-1 rpm that fixed this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.