Clean up remaining PHP-based newsletter pages

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: sgarrity, Assigned: sgarrity)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1263991] )

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
We have a hand full of PHP-based newsletter pages still living in SVN. This bug is to track removing/redirecting them.

The remaining files are (with comments in-line):

http://www.mozilla.com/en-US/newsletter-form.html
I can't find any references to this in the PHP repos. Is it being included by other sites beyond mozilla.org? If not, we can delete it. Shouldn't need a redirect since it was just an include.

http://www.mozilla.com/en-US/newsletter/about_labs/index.html
This looks like it was included in-line somewhere, but I don't see it anywhere on the Labs site. Shouldn't need a redirect since it was just an include.

http://www.mozilla.com/en-US/newsletter/about_mobile/index.html
delete and redirect to /newsletter

http://www.mozilla.com/en-US/newsletter/about_mozilla/index.html
delete and redirect to /newsletter

http://www.mozilla.com/en-US/newsletter/confirm.html
Seems to be a 404 - remove.

http://www.mozilla.com/en-US/newsletter/drumbeat/index.html
Still used anymore? If not, remove.

http://www.mozilla.com/en-US/newsletter/fb/index.html
PHP error already, delete.

http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
This is embedded as an iframe on hacks.mozilla.org. Can we offer a better solution for them?

http://www.mozilla.com/en-US/newsletter/index.html
Already redirected - remove.

http://www.mozilla.com/en-US/newsletter/new/index.html
Maybe redirect to https://www.mozilla.org/en-US/newsletter/recovery/ ?
> http://www.mozilla.com/en-US/newsletter/drumbeat/index.html
> Still used anymore? If not, remove.
not used, delete
Steven, are you sure this one is still being used?

>http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
>This is embedded as an iframe on hacks.mozilla.org. Can we offer a better solution for them?

I thought it was already migrated and could be deleted.
Per Jess for 
http://www.mozilla.com/en-US/newsletter-form.html
"This is still being used. This is the newsletter sign up form for every content page still on php. Can be deleted after everything else has been deleted."
Does that make sense with what you are seeing/
(Assignee)

Comment 4

5 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #3)
> Per Jess for 
> http://www.mozilla.com/en-US/newsletter-form.html
> "This is still being used. This is the newsletter sign up form for every
> content page still on php. Can be deleted after everything else has been
> deleted."
> Does that make sense with what you are seeing/

I don't think this is true. If this is referring to the "Get Monthly News" form in the bottom right of the page (with the little snow-beast on top of it) like on http://mozilla.org/firefox/8.0/releasenotes/ then, no, this is not using the newsletter-form.html file. Rather the footer uses the includes/newsletter.inc.php shown here: http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/includes/newsletter.inc.php?view=markup

(In reply to Jennifer Bertsch [:jbertsch] from comment #2)
> Steven, are you sure this one is still being used? 
> >http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
> >This is embedded as an iframe on hacks.mozilla.org. Can we offer a better solution for them?
> I thought it was already migrated and could be deleted.

It is definitely still in use. If you view-source on http://hacks.mozilla.org, you can see the iframe that includes it:

<iframe src="https://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/"
frameborder="0" scrolling="no" style="width: 100%; height: 300px"></iframe>
Hi Jess-

Could you please comment about http://www.mozilla.com/en-US/newsletter-form.html in comment 4 above?

Thx,
Jen
Flags: needinfo?(jdavis)
(In reply to Jennifer Bertsch [:jbertsch] from comment #2)
> Steven, are you sure this one is still being used?
> 
> >http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
> >This is embedded as an iframe on hacks.mozilla.org. Can we offer a better solution for them?
> 
> I thought it was already migrated and could be deleted.

Steven-  Do you have an idea for a better solution for this one?  If yes, let's do it!  Thanks.
Whiteboard: [kb=1263991]

Comment 9

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #0)

> http://www.mozilla.com/en-US/newsletter-form.html
> I can't find any references to this in the PHP repos. Is it being included
> by other sites beyond mozilla.org? If not, we can delete it. Shouldn't need
> a redirect since it was just an include.

Good to delete. I think this is a super old form from Responsys days.

> 
> http://www.mozilla.com/en-US/newsletter/about_labs/index.html
> This looks like it was included in-line somewhere, but I don't see it
> anywhere on the Labs site. Shouldn't need a redirect since it was just an
> include.

Good to delete. I think this is a super old form from Responsys days.


> http://www.mozilla.com/en-US/newsletter/drumbeat/index.html
> Still used anymore? If not, remove.

Good to delete. I think this is a super old form from Responsys days.
Flags: needinfo?(jdavis)
(Assignee)

Comment 10

5 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #6)
> > >http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
> > >This is embedded as an iframe on hacks.mozilla.org. Can we offer a better solution for them?
> Steven-  Do you have an idea for a better solution for this one?  If yes,
> let's do it!  Thanks.

I'm not sure yet - but I'll look into it.

Also, jbertsch, can you confirm that a delete and mozilla.org/newsletter/ redirect is appropriate for both of these PHP pages?
http://www.mozilla.org/newsletter/about_mozilla/
http://www.mozilla.org/newsletter/about_mobile/
Flags: needinfo?(jbertsch)

Comment 11

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #10)
 
> Also, jbertsch, can you confirm that a delete and mozilla.org/newsletter/
> redirect is appropriate for both of these PHP pages?

I think I can help with these.

> http://www.mozilla.org/newsletter/about_mozilla/

This signup form is on: https://www.mozilla.org/contribute/  - you can re-route to there.


> http://www.mozilla.org/newsletter/about_mobile/

This newsletter doesn't really exist separately from Firefox & You at the moment. Best to reroute to mozilla.org/newsletter. They get the same (mobile) info in the Firefox & You newsletter.
(In reply to Jessilyn Davis from comment #11)
> (In reply to Steven Garrity [:sgarrity] from comment #10)
>  
> > Also, jbertsch, can you confirm that a delete and mozilla.org/newsletter/
> > redirect is appropriate for both of these PHP pages?
> 
> I think I can help with these.
> 
> > http://www.mozilla.org/newsletter/about_mozilla/
> 
> This signup form is on: https://www.mozilla.org/contribute/  - you can
> re-route to there.
> 
> 
> > http://www.mozilla.org/newsletter/about_mobile/
> 
> This newsletter doesn't really exist separately from Firefox & You at the
> moment. Best to reroute to mozilla.org/newsletter. They get the same
> (mobile) info in the Firefox & You newsletter.

+1 Thanks Jess and Steven!
Flags: needinfo?(jbertsch)
(Assignee)

Comment 13

5 years ago
Thanks for the clarification. Also, it turns out that the hacks.mozilla.org form is indeed coming from bedrock already.

I've submitted a pull request to update the redirects (https://github.com/mozilla/bedrock/pull/1671). Once this is in place in production, I'll attach a patch to remove the obsolete files.

Comment 14

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #13)
> Thanks for the clarification. Also, it turns out that the hacks.mozilla.org
> form is indeed coming from bedrock already.
> 

https://www.mozilla.org/en-US/newsletter/hacks.mozilla.org/   is a bedrock page?
(Assignee)

Comment 15

5 years ago
(In reply to Jessilyn Davis from comment #14)
> https://www.mozilla.org/en-US/newsletter/hacks.mozilla.org/   is a bedrock
> page?

Yes, it is in Bedrock.

I didn't think it was initially, because there is a version of it in the PHP site at the same URL:
http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/trunk/en-US/newsletter/hacks.mozilla.org/index.html?view=markup

However, there is also a version of the page in bedrock and I've confirmed that this is the one being used here:
https://github.com/mozilla/bedrock/blob/master/bedrock/newsletter/templates/newsletter/hacks.mozilla.org.html

Comment 16

5 years ago
(In reply to Steven Garrity [:sgarrity] from comment #15)
> (In reply to Jessilyn Davis from comment #14)
> > https://www.mozilla.org/en-US/newsletter/hacks.mozilla.org/   is a bedrock
> > page?
> 
> Yes, it is in Bedrock.
> 
Brilliant! Thanks Steven! I think I was remembering the PHP page and was nervous if the bedrock had been created.

Comment 17

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/7135e923504f1d64862e824aadf6fac119d025c9
Add newsletter redirects for Bug 959310
Also consolidate /b/ bedrock redirects for /newsletter/*

https://github.com/mozilla/bedrock/commit/0d442fe8bffbd47ba023d60687f983ba7a3036ea
Merge pull request #1671 from sgarrity/bug-959310-newsletter-redirects

Add newsletter redirects for Bug 959310
https://www.allizom.org/en-US/newsletter/ fixed on stage
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

5 years ago
Created attachment 8374004 [details] [diff] [review]
Patch to clean up /newsletter/ files in SVN

This patch removes the /newsletter/ pages from SVN now that we have these redirects in place.
Attachment #8374004 - Flags: review?(pmac)
(Assignee)

Comment 20

5 years ago
Reopening until I get the SVN patch reviewed/applied.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
The new apache rules are not working:

http://www.mozilla.org/en-US/newsletter/about_mozilla/

^^ is a 404. This is because of the order of the new rules in global.conf. The catch-all passthrough is first, so all /*/newsletter/* urls go to bedrock, which has no knowledge of /about_mozilla/. So we either need to add redirects to bedrock, or move the [PT] rule after the redirects so that they'll catch the more specific urls first.
Flags: needinfo?(steven)
Just to be clear, this is my bad. I missed it in the review :(

Also, :retornam, please check the redirects when QAing changes that introduce redirects.
(In reply to Steven Garrity [:sgarrity] from comment #0)
> http://www.mozilla.com/en-US/newsletter/hacks.mozilla.org/index.html
> This is embedded as an iframe on hacks.mozilla.org. Can we offer a better
> solution for them?

This was indeed ported to bedrock after we needed to change the old one and found it still using old code. A better solution will hopefully be just using basket directly from the client. I've added CORS support to the basket subscription API in bug 961084. Once this is merged and in prod we should be able to have a form on the hacks blog that submits directly to basket via XHR. The current solution is working fine however, and is like to be much more supported in older browsers.
Comment on attachment 8374004 [details] [diff] [review]
Patch to clean up /newsletter/ files in SVN

Review of attachment 8374004 [details] [diff] [review]:
-----------------------------------------------------------------

Good. We don't have to wait for the fix for the 404s on /about_mozilla/ etc. to push this out since the urls are already hitting bedrock.
Attachment #8374004 - Flags: review?(pmac) → review+

Comment 25

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/57603636c1ce2aa8459dd9121dc2c308cf7e6ffe
Fix order of /newsletter/ redirects for Bug 959310

https://github.com/mozilla/bedrock/commit/6d5ef1c6753c5d2e287443c74d736eecf3ff77cf
Merge pull request #1700 from sgarrity/bug-959310-newsletter-redirects

Fix order of /newsletter/ redirects for Bug 959310
(Assignee)

Comment 26

5 years ago
Patch applied in trunk in r124697, tags/stage in r124698, and tags/production in r124699.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(steven)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.