Logging in with mozilla.com address 'fails'

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: espressive, Assigned: peterbe)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Opened up air.mozilla.org in Firefox 26

Clicked on the Sign in (Persona) button

The Persona pop-up opened up providing me with two email address options:
sneethling@mozilla.com
sneethling@login.mozilla.org

I selected m.c and proceeded to the screen where I am prompted to enter my LDAP password.

After entering the password I see that I am logged in and verified (in the persona window) but, when the Persona pop-up closes, air.m.o states that the login is only for Mozilla employees or vouched Mozillians.org users.

However, if I then navigate to the landing page, I can see the link to the Moco meeting, and clicking on Watch Now, takes me to the video screen and I can watch the meeting.

--

Interesting fact though, once I have authenticated once, logging out and in with the same email address works just fine without any hiccups.
(Assignee)

Comment 1

5 years ago
Thank you so much for filing this. It's puzzling.

One important piece I need to comprehend this is what order you did the following:

* Click the Sign-in button
* Reach a URL that is non-public

I vaguely remember having seen a bug where you go to a URL like https://air.mozilla.org/Some-PRIVATE-company-only-event and it then forces you to sign in and when you do, successfully, you're not sent back to the page you originally requested.
(Reporter)

Comment 2

5 years ago
(In reply to Peter Bengtsson [:peterbe] from comment #1)
> Thank you so much for filing this. It's puzzling.
> 
> One important piece I need to comprehend this is what order you did the
> following:
> 
> * Click the Sign-in button
> * Reach a URL that is non-public
> 
> I vaguely remember having seen a bug where you go to a URL like
> https://air.mozilla.org/Some-PRIVATE-company-only-event and it then forces
> you to sign in and when you do, successfully, you're not sent back to the
> page you originally requested.

I clicked the sign in button on the landing page.
(Assignee)

Comment 3

5 years ago
Is this what you saw? 

https://www.dropbox.com/s/2renl0yufh9ej9w/Screenshot%202014-01-14%2009.35.13.png

The only way I can reproduce the bug is by starting on this URL: https://air.mozilla.org/login-failure/?bid_login_failed=1

I got there because I, correctly, failed to sign in with my "peterbe@gmail.com". From that page, I then attempted with my "peterbe@mozilla.com" and I correctly didn't get signed in. 

By the way, what is sneethling@login.mozilla.org? I've not seen that. And I know that if you try to sign in with that it won't work.
(Reporter)

Comment 4

5 years ago
(In reply to Peter Bengtsson [:peterbe] from comment #3)
> Is this what you saw? 
> 
> https://www.dropbox.com/s/2renl0yufh9ej9w/Screenshot%202014-01-14%2009.35.13.
> png

I would see one of those messages not both at the same time.

> 
> The only way I can reproduce the bug is by starting on this URL:
> https://air.mozilla.org/login-failure/?bid_login_failed=1
> 
> I got there because I, correctly, failed to sign in with my
> "peterbe@gmail.com". From that page, I then attempted with my
> "peterbe@mozilla.com" and I correctly didn't get signed in. 
> 
> By the way, what is sneethling@login.mozilla.org? I've not seen that. And I
> know that if you try to sign in with that it won't work.

There was an email sent out a looong time ago about that and people were asked to test. It had something to do with automated LDAP authentication or some such thing, I cannot exactly remember, sorry ;(

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

5 years ago
Schalk, I could not reproduce the problem you described. It could only be explained as a temporary glitch in Persona maybe. 

However, I did find that the redirect-after-successful-login functionality was really broken which made it impossible to "try again" from the login failure page. 

So I took the nonchalant liberty of morphing this bug to fit that fix. 

We'll continue to keep an eye out for this problem you described.
(Reporter)

Comment 7

5 years ago
Thanks Peter.
(Assignee)

Updated

4 years ago
Assignee: nobody → peterbe
You need to log in before you can comment on or make changes to this bug.